1

Im trying to update the driver for realtek usb wifi adapter.

model : 0bda:8171 RTL8188SU

I used this guide.

sudo apt-get install git build-essential
git clone https://github.com/chunkeey/rtl8192su.git
cd rtl8192su
make
sudo make load

but got this:

Im stuck on 'make' procedure

i followed this link (suggested on irc ubuntu channel) until 1st step only coz of this errors.


questions:

I've read that wifi drivers needs to be reinstalled every after kernel updates, are all kernel updates equal or should i only be reinstalling after a specific kernel update was done?

I tried the ndiswrapper method before. using this

disregarding the step about blacklisting the old driver because wifis cannot be detected.

inspite of disregarding the blacklisting, Wifi became stable,so I assumed it must be the ndiswrapper, but after 2days,after an update,it is intermittent again.


observation after the ndiswrapper procedure:

the driver listed after doing :

sudo lshw -C network

is still unchanged,showing : r8712u , it should be updated to something else right?

That is why Im changing the driver update method into a non-ndiswrapper method. Unfortunately,its not succesfull (yet)

issues im trying to fix:

intermittent wifi connection,fixing it by driver update

  • It is doubtful that an older, less developed driver will solve anything. Please tell us the issue you have and let's work on the basic problem. – chili555 May 10 '18 at 12:33
  • hi chilli555 , issues of the wifi are: 1. intermittent wifi connection 2. changing the driver to the latest version. – obo May 11 '18 at 4:00
  • i do this a lot : sudo -i rmmod r8712u && sudo modprobe r8712u to the point I have to restart ubuntu when its not responding anymore.. ive read theres a bug but it was 2yrs ago askubuntu.com/questions/742347/… – obo May 11 '18 at 4:09
1

There is no evidence that I am aware of that the driver included by default in kernel version 4.4.0-xx is outdated, nor that instability can be rectified by installing a different, maybe older, maybe newer driver. Moreover, I know of no driver that actually compiles and installs.

Instability is sometimes caused by problems in the router such as auto channel select and others.

Please check the settings in the router. WPA2-AES is preferred; not any WPA and WPA2 mixed mode and certainly not TKIP. Second, if your router is capable of N speeds, you may have better connectivity with a channel width of 20 MHz in the 2.4 GHz band instead of automatic 20/40 MHz, although it is likely to affect N speeds. I also have better luck with a fixed channel, either 1, 6 or 11, rather than automatic channel selection. Also, be certain the router is not set to use N speeds only; auto B, G and N is preferred. After making these changes, reboot the router.

Next, I recommend that your regulatory domain be set explicitly. Check yours:

sudo iw reg get

If you get 00, that is a one-size-maybe-fits-all setting. Find yours here: http://en.wikipedia.org/wiki/ISO_3166-1_alpha-2 Then set it temporarily:

sudo iw reg set IS

Of course, substitute your country code if not Iceland. Set it permanently:

sudo nano /etc/default/crda

Change the last line to read:

REGDOMAIN=IS

Proofread carefully, save and close the text editor.

You might also turn off power saving in Network Manager. From the terminal:

sudo sed -i 's/3/2/' /etc/NetworkManager/conf.d/*

Reboot the computer and tell us if there is any improvement.

  • changing router settings is not an option at this time. because Im using prepaid wifi. already did turning off power saving prior to creating this thread.. i might just go & use another atheros chipset instead.. this realtek is very inconsistent :( – obo May 13 '18 at 8:35
  • How about the regulatory domain? Does that help at all? – chili555 May 14 '18 at 20:41
  • hi chili555 thanks a lot for the answers..the regulatory domain works somehow,but connection still drops.. will the regulatory domain interfere with VPN connections? whats the least problematic chipset/ wifi adapter for ubuntu? off topic: how can i get email notifications from this thread? – obo May 17 '18 at 0:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.