2

I currently have nvidia-390 installed on my system (integrated Intel HD graphics stopped working for some odd reason). Steam was working with Intel graphics, and with nvidia-340, I believe. The last time I used the laptop's NVIDIA GPU was a year ago. Main reason why I'm not using nvidia-340 (which was recommended on the driver manager) was because it wouldn't run after upgrading to 18.04, and had to use nvidia-390 and install xserver-xorg-video-nvidia-390.

Yesterday, I tried installing xserver-xorg-video-nvidia-396, and remove anything related to nvidia-390. That fixed my problem, including the menu lag on Kubuntu. However, I can't use my second display after that, which made me unable to use my laptop afterwards. I assumed it was because there was no nvidia-396 package, so I removed xserver-xorg-video-nvidia-396, and re-installed nvidia-390 and xserver-xorg-video-nvidia-390. Now, I'm back to where I began.

I tried running glxinfo, and this returned:

name of display: :0
Error: couldn't find RGB GLX visual or fbconfig

My laptop is a Lenovo Z40, with Core i7-4510U & GeForce 820M.

lspci | grep -i vga

00:02.0 VGA compatible controller: Intel Corporation Haswell-ULT Integrated Graphics Controller (rev 0b)

lspci | grep -i nvidia

03:00.0 3D controller: NVIDIA Corporation GF117M [GeForce 610M/710M/810M/820M / GT 620M/625M/630M/720M] (rev a1)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.