2

I have a laptop with with the Intel Dual Band Wireless-AC 7260 and am running Ubuntu 18.04 (although the problem existed with 17.10 and I presume this is a general problem). At home the Wifi works well, however, on some networks it will intermittently disconnect. Using Gnome network manager and turning the Wi-fi off and back on could fix the issue, but not always. This could happen numerous times a day.

  • Thanks psiphi75, your fix is good. Works for me on Ubuntu 18.04.1 LTS. vi /etc/default/crda. Set to proper REGDOMAIN vi /etc/modprobe.d/iwlwifi.conf Add this options iwlwifi bt_coex_active=0 swcrypto=1 11n_disable=8 – Nnaemeka Emejulu Feb 4 '19 at 18:54
2

After much research and reading the Kernel documentation on this, I found that making all the following changes work.

Change the wi-fi country code (thanks to this post). As root edit /etc/default/crda and set the following to your country code:

REGDOMAIN={ISO COUNTRY CODE}

Disable Bluetooth, although this is a dual-band adapter, it's not good at handling Bluetooth and wi-fi at the same time. From the Kernel documentation:

For users of these devices who have problems when Wi-Fi and Bluetooth are running concurrently, we suggest to disable BT Coex by loading iwlwifi with bt_coex_active=0 as a module parameter.

Also from the Kernel documentation also discusses that the device does not handle 2.4 Ghz noise very well and recommends the following:

- Disable Wi-Fi's power save (prevent the PCIe link to go to power save): power_save=0 module parameter for iwlmvm
- Disable USB3 in BIOS (if possible), it not, just stop using it
- Disable 40MHz on 2.4GHz: cfg80211_disable_40mhz_24ghz module parameter
- Use 5GHz band (on devices that support 5GHz operation)

In a nutshell, I did not disable USB3 in BIOS. But did the others, to implement these changes add the following line to /etc/modprobe.d/iwlwifi.conf:

options iwlwifi bt_coex_active=0 swcrypto=1 11n_disable=8 

UPDATE: Thanks to @chili555, the Kernel driver page appears to be out-dated/incorrect, the power_scheme value does not exists and appears that we should use power_save=0. Documentation updated.

A good resource for debugging the iwlwifi driver is https://support.system76.com/articles/wireless/

  • Please check: modinfo iwlwifi. I think you mean power_level or power_save. power_scheme is not an available parameter. If you mean for this parameter to apply to iwlmvm, then it needs its own conf file:options iwlmvm power_scheme=1 – chili555 May 9 '18 at 22:09
  • @chili555, thanks, documentation updated. – psiphi75 May 10 '18 at 23:00
1

You can fix this issue temporarily by running this code (The selected Country should support Dual-band 5Ghz US/DE/...):

 # iw reg set US

or add this as a permanent solution:

echo "COUNTRY=US" > /etc/sysconfig/regdomain

And these code as check:

 # iw reg get
 # iw list

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.