whenever I go to getpersonas.com or youtube the page loads like this:

Screenshot Example

How can I fix this?

  • I'm experiencing this too. My findings: it is not OS dependent (also happens with Windows 7), it is not browser dependent (Opera, Chrome/Chromium, Firefox), it doesn't matter if I connect via my router or the modem (PPPoE), I tried different DNS w/o luck. One page that fails quite often for me is bugzilla.gnome.org - all in all: this doesn't look like an Ubuntu problem. :-|
    – htorque
    Oct 30 '10 at 22:54

The reason for this is because your browser is not loading the stylesheet, which is hosted on another domain. Possible reasons could be due to the stylesheet domain being blocked or because your browser is failing to get DNS resolution for it.

Try reaching getpersonas.com through a web proxy like:


If the site displays properly via proxy, then try to disable ipv6. To do that in Firefox:

  1. Type about:config in the address bar, press Enter.
  2. Find network.dns.disableIPv6 in the list.
  3. Right-click -> Toggle.
  4. Restart Firefox and try again.

You can also disable ipv6 on the system level, so other browsers don't get affected by ipv6 issues. To do that, open the file /etc/default/grub with an editor:

gksudo gedit /etc/default/grub

Then change the following line:


With the following line:

GRUB_CMDLINE_LINUX_DEFAULT=”ipv6.disable=1 quiet splash”

Then update grub:

sudo update-grub

You can also try a different DNS server like OpenDNS or Google Public DNS.

  • Why do you think this is the reason?
    – JanC
    Oct 30 '10 at 0:01
  • Because that is a problem that happens on Mozilla sites. For instance, is common for users with ipv6 enable to not being able to install extensions and I have already seen css issues as well. Oct 30 '10 at 0:27
  • @JanC BTW, the personas site pulls the css from a different domain getpersonas-cdn.mozilla.net/static/min/?g=css&r=74591, which is probably the cause of the ipv6 interference. Oct 30 '10 at 0:38
  • That domain doesn't have AAAA records in DNS, so that shouldn't give problems...
    – JanC
    Oct 30 '10 at 4:36
  • @lovinglinux turning off ipv6 in about:config didn't helped me, I also have a windows on the same computer and it works there (in case this could help), using latest ubuntu 10.10
    – Omu
    Oct 30 '10 at 21:51

It looks like you aren't loading the stylesheet. Clear your cache or hit F5.


Alright I finally got it working. The problem was my ISP's DNS doesn't play nice with Ubuntu. So I changed my DNS to OpenDNS and that fixed it.


Looks like there is a problem with the CSS file(s). Try Ctrl+F5 and/or Shift+F5 to force a reload of not only the page but the associated files.

If that doesn't work you could try clearing your cache (an option in Clear Recent History).


You could try to set up a new Firefox profile for testing reasons. First, make sure all instances of Firefox are closed! It might take some time for the process to end even though Firefox is not visible any more. If the commands below do not work make sure Firefox is closed by typing the following in a shell.

killall firefox-bin

Then run the Firefox Profile Manager. You can do that by entering the following command from a shell or by pressing Alt+F2 and entering it there:

firefox -profilemanager

You can setup a new profile there and try if it works with that fresh one. Be aware that the newly created profile will be set as new default. Do switch back to your original profile you have to start the profile manager again and select to start the appropriate profile.

See MozillaZine for more information on the profile manager.

If just read lovinglinux's answer and just wanted to let you know that - in case you tried to solve the issue with a new profile - you should get the same problem again, as setting up a new profile also uses the default about:config settings which are to use ipv6 by default (network.dns.disableIPv6=False). If the new profile solved your problems we have to search somewhere else for the problem. See MozillaZine for details on the option.


My solution is to use the latest Opera 10 browser with Turbo Mode turned on.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.