4

This question already has an answer here:

I'm running Ubuntu 18.04 LTS, and I can't install from new PPA's. It gives me a 404 error every time I try to update the package lists.

curtice@linuxloverpc:~$ sudo apt update
[sudo] password for curtice: 
Hit:1 http://security.ubuntu.com/ubuntu bionic-security InRelease
Hit:2 http://us.archive.ubuntu.com/ubuntu bionic InRelease               
Hit:3 http://us.archive.ubuntu.com/ubuntu bionic-updates InRelease       
Hit:4 http://ppa.launchpad.net/bartbes/love-stable/ubuntu bionic InRelease
Ign:5 http://ppa.launchpad.net/gnome-shell-extensions/ppa/ubuntu bionic InRelease
Hit:6 http://ppa.launchpad.net/obsproject/obs-studio/ubuntu bionic InRelease  
Hit:7 http://ppa.launchpad.net/papirus/papirus/ubuntu bionic InRelease        
Err:8 http://ppa.launchpad.net/gnome-shell-extensions/ppa/ubuntu bionic Release
  404  Not Found [IP: 91.189.95.83 80]
Reading package lists... Done
E: The repository 'http://ppa.launchpad.net/gnome-shell-extensions/ppa/ubuntu bionic Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

I did not re-enable repositories after a distro upgrade, I did not incorrectly type the repo name, and the repository obviously exists at http://ppa.launchpad.net/gnome-shell-extensions/ppa/ubuntu/

How do I fix this?

marked as duplicate by wjandrea, karel, Fabby, Melebius, Zanna May 11 '18 at 15:22

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • @N0rbert The question you linked is not relevant to my situation. I use 18.04 and he uses something else from 6 years ago. – Curtice Gough May 9 '18 at 17:12
  • 3
    @CurticeGough The repo management system still works the same way. – wjandrea May 9 '18 at 17:24
6

The apt-get update in your question states that gnome-shell-extensions/ppa does not have packages for Ubuntu 18.04 LTS Bionic Beaver.

You should simply disable this repository with

sudo add-apt-repository -r ppa:gnome-shell-extensions/ppa

And then continue to use apt as usual.

Not the answer you're looking for? Browse other questions tagged or ask your own question.