2

I've done a fresh install of ubuntu 18.04. My system is the following:

lucas@test:~$ inxi -F
System:    Host: test Kernel: 4.15.0-20-generic x86_64 bits: 64 Desktop: Gnome 3.28.1 Distro: Ubuntu 18.04 LTS
Machine:   Device: laptop System: Hewlett-Packard product: HP ENVY 15 Notebook Pc v: 09A2100000400000000000000 serial: N/A
           Mobo: Hewlett-Packard model: 228D v: 77.12 serial: N/A UEFI: Insyde v: F.04 date: 05/15/2014
Battery    BAT0: charge: 43.2 Wh 100.0% condition: 43.2/43.2 Wh (100%)
CPU:       Dual core Intel Core i7-4510U (-MT-MCP-) cache: 4096 KB
           clock speeds: max: 3100 MHz 1: 1327 MHz 2: 1084 MHz 3: 1000 MHz 4: 982 MHz
Graphics:  Card-1: Intel Haswell-ULT Integrated Graphics Controller
           Card-2: NVIDIA GM108M [GeForce 840M]
           Display Server: x11 (X.Org 1.19.6 ) drivers: modesetting,nvidia (unloaded: fbdev,vesa,nouveau)
           Resolution: 1920x1080@60.38hz, 1440x900@59.89hz
           OpenGL: renderer: GeForce 840M/PCIe/SSE2 version: 4.6.0 NVIDIA 390.48
Audio:     Card-1 Intel 8 Series HD Audio Controller driver: snd_hda_intel Sound: ALSA v: k4.15.0-20-generic
           Card-2 Intel Haswell-ULT HD Audio Controller driver: snd_hda_intel
Network:   Card-1: Broadcom Limited BCM43142 802.11b/g/n driver: wl
           IF: wlo1 state: up mac: d8:5d:e2:cc:38:5d
           Card-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller driver: r8169
           IF: eno1 state: down mac: 70:5a:0f:1c:fb:cd
Drives:    HDD Total Size: 1000.2GB (45.1% used)
           ID-1: /dev/sda model: ST1000LM024_HN size: 1000.2GB
Partition: ID-1: / size: 228G used: 6.0G (3%) fs: ext4 dev: /dev/sda2
           ID-2: /home size: 681G used: 407G (64%) fs: ext4 dev: /dev/sda3
           ID-3: swap-1 size: 8.00GB used: 0.00GB (0%) fs: swap dev: /dev/sda4
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 65.0C mobo: N/A gpu: 38C
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 276 Uptime: 41 min Memory: 3103.8/15970.9MB Client: Shell (bash) inxi: 2.3.56 

Nevertheless, I get high CPU spikes from time to time eventough I really do use it so far for web browsing and libreoffice. With htop I get to see that:

  • Firefox consumes most of the CPU which makes the fans of the laptop go crazy.
  • doing apt-get upgrade makes CPU go high
  • playing youtube videos above 50% of CPU
  • etc ...

Is there anything I can look at to find out what's going on?

  • You can try sudo cpufreq-set -c 0 -r -g powersave. Installing laptop-mode-tools might help. Otherwise, you might need to install a different kernel – xiota May 9 '18 at 14:32
  • Hi! I've tried your suggestion but it behaves the same. What I also see is that it takes a lot for applications to start (cpu goes high when launching apps / so fans go crazy ). Could disks be a bottleneck as well? Any other idea? Something to read? I'm using kernel 4.15 which is pretty new ... would a newer make any difference? To sum up: also playing videos still consume high cpu and make fans spin a lot ... – Lucas Aimaretto May 10 '18 at 0:26
  • Ok ... I'll give kernel upgrade a try then. Did you use UKUU (Ubuntu Kernel Update Utility)? Or may be apt to install a new kernel? Or did you download the .deb and did dpkg -i? ... Also, as per the link you've shared, the newest/latest I see is 4.16.8 ... – Lucas Aimaretto May 10 '18 at 0:48
  • Ok, I have now Linux 4.17.0-041700rc4-generic. Things don't seem better. i.e. MATLAB takes long to start up (cpu/fans) and Firefox as well (noticeable with new pages to open). Not to mention that using this kernel disabled my nvidia card ... :-( ... glxinfo|egrep "OpenGL vendor|OpenGL renderer" shows Intel instead of Nvidia ... any other hint? – Lucas Aimaretto May 11 '18 at 16:50
  • 1
    Did you try the latest 4.16 kernel also? Did you use an older version of Ubuntu previously without problems? No other ideas of where to look beyond that. – xiota May 12 '18 at 3:22
0

Solved with kernel 4.13.4

  1. Download and install it with UKUU.
  2. Put this kernel in #1 position from GRUB (I've used GRUB Customizer)

No more 100% fan.

  • 1
    It is better to provide good answer. – Eranda Peiris Jun 2 '18 at 16:08
  • Since I'm lost with this and trying a new kernel was not such a big deal, I tried 4.13.4: nothing changed. Symptoms remain ... @mander, what's your system if I may know? Just to compare both ... – Lucas Aimaretto Jun 2 '18 at 18:45
  • 1
    xeon e5-2670 mobo x79 32gb ddr3 symptoms were high fan. I've upgraded my 17.10 gnome ubuntu (no issue) to 18.04 LTS, with the previous kernel (4.13.4) fan is ok for me – mander Jun 2 '18 at 20:58
  • @mander: ok, I see ... I believe that we are talking about different things now. My system is a laptop, which are known oftentimes for overheating problems ... I think yours is a desktop chassis, is it? I was looking for some solutions in the field of notebooks ... – Lucas Aimaretto Jun 8 '18 at 16:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.