4

I have installed postgres 10 and pgadmin4 in my Ubuntu 18.04 version. everything went fine. I cannot open the pgadmin gui. what might be the reason. it simply wont open. Does it require Qt? how do i check if I got Qt on my ubuntu? PS: (Also Teamviewer App is also not starting up). Looks like it uses PyQt for the GUI of the application.(atleast that what i heard) PgAdmin 3 is working fine. These are the steps I have done.

  1. Create the file /etc/apt/sources.list.d/pgdg.list and add a line for the repository

    deb http://apt.postgresql.org/pub/repos/apt/ bionic-pgdg main
    
  2. Import the repository signing key, and update the package lists

    wget --quiet -O - https://www.postgresql.org/media/keys/ACCC4CF8.asc | sudo apt-key add -
    sudo apt-get update
    
  3. install posgtresql

    sudo apt-get install postgresql-10 
    
  4. install pgadmin 4

    sudo apt-get install pgadmin4
    

EDIT: Launching from the command line, there is a first output:

`QApplication: invalid style override passed, ignoring it.`

then as @DennyMueller mentioned, a "Fatal Error" pop-up window saying:

`An error occurred initialising the tray icon`

closed as unclear what you're asking by David Foerster, Elder Geek, Kevin Bowen, Zanna, waltinator May 27 '18 at 15:26

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • 4
    How exactly are you trying to start the application? Can you please try again from a terminal to check for possible error messages. Please edit your question to describe the result. Thanks. – David Foerster May 21 '18 at 19:23
  • 1
    Same issue here. pgadmin4 doenst start @ 18.04 "An error orccured initializing the tray icon" shows up after a while. – Denny Mueller May 28 '18 at 12:28
  • @DennyMueller We're reopening the question, so you can edit it and provide more information that the OP did not provide. – Fabby May 29 '18 at 19:36
  • I'm having the same issue. Did anyone find a solution? – tet Aug 4 '18 at 11:59
  • Just in case you get An error occurred initialising the tray icon then install the topicons gnome extension extensions.gnome.org/extension/495/topicons – Denny Mueller Aug 27 '18 at 11:58