5

I freshly installed Ubuntu 18.04 last week, meaning I have not upgraded from 16.04, rather formatted the hard drive and installed 18.04.

I am trying to install texlive-full, but whenever I use:

sudo apt install texlive-full

this is what I get:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies.
 texlive-full : Depends: asymptote but it is not going to be installed
                Depends: cm-super (>= 0.3.3-3) but it is not going to be installed
                Depends: context but it is not going to be installed
                Depends: dvipng but it is not going to be installed
                Depends: feynmf but it is not going to be installed
                Depends: fragmaster but it is not going to be installed
                Depends: latex-cjk-all (>= 4.6.0+cvs20060714-2) but it is not going to be installed
                Depends: latexmk but it is not going to be installed
                Depends: prerex (> 6.5.3-1) but it is not going to be installed
                Depends: purifyeps but it is not going to be installed
                Depends: texlive-base (>= 2017.20170628) but it is not going to be installed
                Depends: texlive-bibtex-extra (>= 2017.20170628) but it is not going to be installed
                Depends: texlive-binaries (>= 2017.20170524.44437)
                Depends: texlive-extra-utils (>= 2017.20170628) but it is not going to be installed
                Depends: texlive-font-utils (>= 2017.20170628) but it is not going to be installed
                Depends: texlive-fonts-extra (>= 2017.20170628) but it is not going to be installed
                Depends: texlive-fonts-extra-doc (>= 2017.20170628) but it is not going to be installed
                Depends: texlive-fonts-recommended (>= 2017.20170628) but it is not going to be installed
                Depends: texlive-fonts-recommended-doc (>= 2017.20170628) but it is not going to be installed
                Depends: texlive-formats-extra (>= 2017.20170628) but it is not going to be installed
                Depends: texlive-games (>= 2017.20170628) but it is not going to be installed
                Depends: texlive-humanities (>= 2017.20170628) but it is not going to be installed
                Depends: texlive-humanities-doc (>= 2017.20170628) but it is not going to be installed
                Depends: texlive-lang-arabic (>= 2017.20170628) but it is not going to be installed
                Depends: texlive-lang-chinese (>= 2017.20170628) but it is not going to be installed
                Depends: texlive-lang-cjk (>= 2017.20170628) but it is not going to be installed
                Depends: texlive-lang-cyrillic (>= 2017.20170628) but it is not going to be installed
                Depends: texlive-lang-czechslovak (>= 2017.20170628) but it is not going to be installed
                Depends: texlive-lang-english (>= 2017.20170628) but it is not going to be installed
                Depends: texlive-lang-european (>= 2017.20170628) but it is not going to be installed
                Depends: texlive-lang-french (>= 2017.20170628) but it is not going to be installed
                Depends: texlive-lang-german (>= 2017.20170628) but it is not going to be installed
                Depends: texlive-lang-greek (>= 2017.20170628) but it is not going to be installed
                Depends: texlive-lang-italian (>= 2017.20170628) but it is not going to be installed
                Depends: texlive-lang-japanese (>= 2017.20170628) but it is not going to be installed
                Depends: texlive-lang-korean (>= 2017.20170628) but it is not going to be installed
                Depends: texlive-lang-other (>= 2017.20170628) but it is not going to be installed
                Depends: texlive-lang-polish (>= 2017.20170628) but it is not going to be installed
                Depends: texlive-lang-portuguese (>= 2017.20170628) but it is not going to be installed
                Depends: texlive-lang-spanish (>= 2017.20170628) but it is not going to be installed
                Depends: texlive-latex-base (>= 2017.20170628) but it is not going to be installed
                Depends: texlive-latex-base-doc (>= 2017.20170628) but it is not going to be installed
                Depends: texlive-latex-extra (>= 2017.20170628) but it is not going to be installed
                Depends: texlive-latex-extra-doc (>= 2017.20170628) but it is not going to be installed
                Depends: texlive-latex-recommended (>= 2017.20170628) but it is not going to be installed
                Depends: texlive-latex-recommended-doc (>= 2017.20170628) but it is not going to be installed
                Depends: texlive-luatex (>= 2017.20170628) but it is not going to be installed
                Depends: texlive-metapost (>= 2017.20170628) but it is not going to be installed
                Depends: texlive-metapost-doc (>= 2017.20170628) but it is not going to be installed
                Depends: texlive-music (>= 2017.20170628) but it is not going to be installed
                Depends: texlive-pictures (>= 2017.20170628) but it is not going to be installed
                Depends: texlive-pictures-doc (>= 2017.20170628) but it is not going to be installed
                Depends: texlive-plain-generic (>= 2017.20170628) but it is not going to be installed
                Depends: texlive-pstricks (>= 2017.20170628) but it is not going to be installed
                Depends: texlive-pstricks-doc (>= 2017.20170628) but it is not going to be installed
                Depends: texlive-publishers (>= 2017.20170628) but it is not going to be installed
                Depends: texlive-publishers-doc (>= 2017.20170628) but it is not going to be installed
                Depends: texlive-science (>= 2017.20170628) but it is not going to be installed
                Depends: texlive-science-doc (>= 2017.20170628) but it is not going to be installed
                Depends: texlive-xetex (>= 2017.20170628) but it is not going to be installed
                Depends: tipa (>= 2:1.2-2.1) but it is not going to be installed
                Depends: vprerex (> 6.5.3-1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Suggestions?

Edit: this the output of sudo apt-cache policy texlive-full:

$ sudo apt-cache policy texlive-full
texlive-full:
  Installed: (none)
  Candidate: 2017.20180305-1
  Version table:
     2017.20180305-1 500
        500 http://it.archive.ubuntu.com/ubuntu bionic/universe amd64 Packages
        500 http://it.archive.ubuntu.com/ubuntu bionic/universe i386 Packages
6
  • Check images in my other answer - do you have enabled all software sources? Also I recommend to switch to Main server.
    – N0rbert
    May 9 '18 at 17:52
  • Switched to Main Server. Did sudo apt update. Still same error. May 9 '18 at 17:59
  • @N0rbert also yes, I have enabled all the software sources. May 9 '18 at 18:06
  • Try to remove all apt-lists with sudo rm -rf /var/lib/apt/lists/* and then retry sudo apt update, sudo apt install texlive-full.
    – N0rbert
    May 9 '18 at 18:09
  • Same error again. May 9 '18 at 18:13
4

During chat session we discovered that OP had texlive-related package from JonathonF's PPA:

$ dpkg -l | grep york
ii libkpathsea6:amd64 2018.20180129.46472-0york1~16.04 amd64 TeX Live: path search library for TeX (runtime part

We removed this package with

sudo apt purge libkpathsea6

And then installed TeXLive

sudo apt install texlive-full
-1

I had similar issues and removing the old package libsynctex1 helped me fix this. Forgot to check which version I had installed before I removed it

sudo apt purge libsynctex1
sudo apt install texlive-full
0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.