1

Actually, I wanted to install pip because I needed to install pycurl which was needed for using Wfuzz. The main fact is that I need to install pip.

I remembered that I had already installed pip once but since I was getting some kind of weird errors, I just removed pip using

sudo apt-get remove python-pip

But now, when I am using

sudo apt-get install python-pip

The pip V 8.1 is getting installed, but when I am trying to use it, the error shows.

bash: /home/coder/.local/bin/pip: No such file or directory

I already went through this Problem installing pip: pip command not found

But there are already 3 pip files at that location, named pip, pip2 and pip2.7

So what should I do now? Any help will be much appreciated as I really need to use the tool wfuzz for other purposes.

OS: Ubuntu 16.04

  • @Dadep. That problem seems different though I tried purging and reinstalling yet no success – john400 May 9 '18 at 14:26
  • Did you try to install with yum or like this : pip.pypa.io/en/stable/installing ? – Dadep May 9 '18 at 14:28
  • Hey I was able to install it. I think I just closed and opened my terminal again. Thanks for the help too. But now I am having problems with installing pycurl using the command >pip install pycurl. But its giving some error – john400 May 9 '18 at 14:29
  • 1
    just open new question, for pycurl installation if you need help – Dadep May 9 '18 at 14:30
1

Had a similar problem a while ago. If I remember correctly, it was solved by purging and reinstalling with

sudo apt-get purge python-pip

followed by

sudo apt-get update
sudo apt-get install python-pip

Purge removes configuration files as well as uninstalling the package.

1

Probably pip is hashed at its previous location. To confirm, run type pip. The output may be

pip is hashed (/home/coder/.local/bin/pip)

If yes, run hash -d pip. That will fix it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.