I have setup my backup folder and put the Automatic backups switch to on. In the Overview tab I cant press the "Back Up Now" because it is grayed out.

I am using Ubuntu 11.10 and here is the content of ~/.gconf/apps/deja-dup/%gconf.xml :

$ cat  ~/.gconf/apps/deja-dup/%gconf.xml
<?xml version="1.0"?>
<entry name="delete-after" mtime="1328975617" type="int" value="7"/>
<entry name="periodic-period" mtime="1328975577" type="int" value="1"/>
<entry name="exclude-list" mtime="1328975572" type="list" ltype="string">
    <li type="string">
<entry name="periodic" mtime="1328988637" type="bool" value="true"/>
<entry name="backend" mtime="1328975520" type="string">

7 Answers 7


Shorter version

Ctrl+Alt+t to open a terminal

pkill deja-dup

Re-run the "Backups" program and try again.

  • 9
    I also had to pkill duplicity before I could run a backup.
    – crockeea
    Apr 17, 2019 at 18:18
  • Ohhh. Perfect. I was getting an error when backing up automatically (like this one: askubuntu.com/questions/1127293/…) which I could not resolve. Then I noticed the buttons are greyed out - followed your advice, everything works again now!
    – Janina
    Aug 20, 2019 at 7:07

In my case, there was no backup running but deja-dup had a couple of things running.

I did a ps -eaf | grep dup and killed the pids. Then I started DejaDup from the menu and the button was active.

  • 1
    I used killall deja-dup. My problem was that i used an external drive, and i'ts not automounted, so the program startup didn't read any backup source. What it's a bit surprising it's that it can backup once you mount because the monitor, but don't enable Restore button.
    – m3nda
    Oct 5, 2015 at 7:44

That button is grayed out when a backup (or restore) is already in progress. Maybe one was running in the background?

Is the button enabled now?

  • I found the problem. I could not make any backup on my backup drive because it was created with an earlier install. So I have no write access to this disk. I am still trying to figure how to fix this. I tried chmod and chown without success. I am locked out of my backup drive...
    – 01BTC10
    Mar 18, 2012 at 15:45
  • 2
    For me, it was the DejaDup popup window asking me to enter a passphrase to encrypt my first backup with.
    – Nemo
    Sep 1, 2012 at 18:19
  • Thanks, good to know. Since there is no progress bar it is impossible to tell. I corroborated this by looking at the running processes.
    – alfC
    Jul 12, 2016 at 19:05
  • 1
    Yes, DejaDup has a horrible UI and doesn't tell you when it's running, much less report progress.
    – Cerin
    Oct 27, 2016 at 19:38
  • Same issue. For me, there was a pop-window asking for entering a password minimized, which I did not notice, and it seems the main backup interface was waiting on me.
    – M J
    Jul 8, 2017 at 1:55
ps aux | grep deja
kill <pid of "deja-dup --backup --auto">

Immediately the backup button becomes active.

This should be reported as a bug as the frontend should either have a button to terminate running backups or automatically reconcile concurrent backups.

  • Doing this solved my problem too. Interesting to note that no backup had occurred for almost 2 weeks even though daily backups were selected. In addition, within a few seconds of killing deja-dup --backup, a new backup started automatically and continued to normal completion. It will be interesting to see if the normal auto backup completes normally tomorrow.
    – rickhg12hs
    Jun 12, 2017 at 7:10

My 'back up now' button was disabled. In my case the problem was that when I opened the Deja Dup config, the 'storage' option was set to 'Ubuntu One', and it opened another window for logging into that.

I changed the storage setting to a local drive, but it took me a while to realise I had to cancel the Ubuntu One login before Deja Dup would allow me to run a backup.

  • 1
    This exactly what had happened with my setup. Aug 27, 2012 at 22:27
  • Same thing here.
    – Cloud
    Sep 29, 2013 at 4:17

I ended the process found in the system monitor and the buttons immediately 'ungreyed'. They way I got into the problem was canceling a backup to postpone figuring out a password for it. I had shut down the machine several times since then but it was still stuck there I guess.


It might also be that you don't have to kill the process, because it is already doing what you want it to do in the background. I just opened the destination folder and I'm seeing that lots of backup files are being created.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.