6

I have Trash bin and Hard Drive icons on my desktop. Whenever I paste or download any file on desktop it overlaps over desktop icons. How can I prevent this behaviour?

2

Are you using Nemo or Nautilus as the desktop manager? I'm using Nemo, and I had similar problems each time I rebooted by PC. Existing icons on the desktop would overlap with the Trash icon. I found the solution online. Here's what you need to do. In the Terminal type:

gsettings set org.nemo.desktop use-desktop-grid false

or alternatively, make the same change using the dconf editor.

See: This bug link for the solution (scroll to the very last entry). In case the link moves or gets deleted or does not open for any reason, I've pasted the relevant part below:

Found a solution for this issue. That is to disable 'use-desktop-grid'.
Open dconf-editor and deselect org.nemo.desktop.use-desktop-grid
or just run:
gsettings set org.nemo.desktop use-desktop-grid false

If you're using Nautilus, perhaps you may be able to find an equivalent setting that you could change.

Good Luck.

2
  • 1
    Welcome to Ask Ubuntu! Excellent first answer! +1
    – Fabby
    Aug 25 '18 at 23:45
  • After ~10 minutes of searching for "how to tell if I'm using Nautilus or Nemo"; could the title of this question be changed to "Prevent desktop icons and files from overlapping in Ubuntu 18.04 if using NEMO"? Or, does the above command gsettings set org.nemo.desktop use-desktop-grid false ...work in Nautilus as well? I would rather not issue a command that could potentially render my entire system useless (again). Apologies for not knowing how to format cleanly.
    – 00fruX
    Nov 8 '18 at 18:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.