1

I'm trying to get my Raspberry Pi wireless working so I can connect to my two seperate networks like I had with Raspbian. I followed a few tutorials online, this was the last one that seemed to get me somewhere: https://medium.com/a-swift-misadventure/how-to-setup-your-raspberry-pi-2-3-with-ubuntu-16-04-without-cables-headlessly-9e3eaad32c01

But still no network.

ifconfig:

eth0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.1.17  netmask 255.255.255.0  broadcast 192.168.1.255
        inet6 fe80::ba27:ebff:fea3:7b04  prefixlen 64  scopeid 0x20<link>
        ether b8:27:eb:a3:7b:04  txqueuelen 1000  (Ethernet)
        RX packets 619  bytes 142348 (142.3 KB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 326  bytes 47342 (47.3 KB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1000  (Local Loopback)
        RX packets 211  bytes 52909 (52.9 KB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 211  bytes 52909 (52.9 KB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

iwconfig:

lo        no wireless extensions.

eth0      no wireless extensions.

wlan0     IEEE 802.11  ESSID:off/any
          Mode:Managed  Access Point: Not-Associated   Tx-Power=0 dBm
          Retry short limit:7   RTS thr=2347 B   Fragment thr:off
          Power Management:on

lsusb:

Bus 001 Device 005: ID 046d:c52b Logitech, Inc. Unifying Receiver
Bus 001 Device 004: ID 0bda:8176 Realtek Semiconductor Corp. RTL8188CUS 802.11n WLAN Adapter
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. SMSC9512/9514 Fast Ethernet Adapter
Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp. SMC9514 Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Tried this: https://help.ubuntu.com/lts/serverguide/network-configuration.html.en

nmcli radio wifi on:

Error: NetworkManager is not running.

nmcli --version:

nmcli tool, version 1.10.6

Any Help is appreciated, I'm getting tired of tripping over my cable and not being able to connect to wireless and the development PLC.

lsb_release -d:

Description:    Ubuntu 18.04 LTS

cat /etc/netplan/*.yaml:

# This file is generated from information provided by
# the datasource.  Changes to it will not persist across an instance.
# To disable cloud-init's network configuration capabilities, write a file
# /etc/cloud/cloud.cfg.d/99-disable-network-config.cfg with the following:
# network: {config: disabled}
network:
    version: 2
    ethernets:
        eth0:
            dhcp4: true
            match:
                macaddress: b8:27:eb:a3:7b:04
            set-name: eth0
  • Please edit your question to add the result of these terminal commands: lsb_release -d and also: cat /etc/netplan/*.yaml Welcome to Ask Ubuntu. – chili555 May 9 '18 at 12:43
2

You need to update your netplan config.

Below is my config at /etc/netplan/00-snapd-config.yaml. I initially created it using console-conf, but had to edit it manually to make it work.

ubuntu@ubuntu:~$ sudo cat /etc/netplan/00-snapd-config.yaml
# This is the network config written by 'console_conf'
network:
  ethernets:
    eth0:
      dhcp4: true
      match:
        macaddress: b8:27:eb:03:91:12
      set-name: eth0
  version: 2
  wifis:
    wlan0:
      access-points:
        my_wifi_ssid: {password: my_wifi_password}
      addresses: []
      dhcp4: true
      nameservers: {}

I first installed console-conf using sudo apt install console-conf and then run it using sudo console-conf.

Interestingly, even this tool wasn't able to generate a correct config. This error message appeared:

Network configuration failed: 'Error in network definition 
//etc/netplan/00-snapd-config.yaml line 4 column 6: eth0:
set-name: requires match: properties\n'

I hand-modified /etc/netplan/00-snapd-config.yaml - I copied over the ethernets section from 50-cloud-init.yaml and used consistent indentation everywhere.

Lastly I run sudo netplan apply. Voila - Internet now works without the Ethernet cable!

PS: I doubt that you need to go through console-conf - just copy my config and adapt it to your use case.

  • I ran console-conf and tried to set up my wifi on my Pi 3B+. I made it all the way through the config and then it gave me that same obscure error about "properties" being required in the yaml file. I tried to cancel but there is apparently no way out of this crap utility. Even cycling the power just takes me right back to it. I'm going to have to start building my R-Pi from scratch. To anyone reading this - If you use console-conf you're going to have a bad time. – David Powell Jan 21 at 1:26
  • I agree, it's a terrible experience. Try skipping console-conf altogether and just copying and adapting my config. – kkom Jan 24 at 20:19

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.