3

So I install a brand new ubuntu 18.04 in virtual box. I installed both host extensions and guest additions. My host system in a windows 10. I activated the 3D acceleration in my VM settings.

when I ask ubuntu, I thinks it answers that I do have 3D acceleration :

glxinfo | grep direct
direct rendering: Yes

The thing is, gnome 3 is not running smooth at all. No fancy effect or anything. Any lead is welcome, from the good combination of versions to maybe just tell my guest ubuntu how to use the 3D acceleration ?

  • this is duplicated of askubuntu.com/questions/1029585/… – rodvlopes May 9 '18 at 13:10
  • 1
    How is it a duplicate ? My vm does not freeze on startup (or ever), it starts with 3D acceleration activated in the vbox settings and a glxinfo inside the VM tells me the direct rendering is activated. – Tom May 9 '18 at 13:15
  • sure, it's just quite similar. – rodvlopes May 9 '18 at 18:15
0

So, if you have nothing against using unity instead of gnome (still on ubuntu 18.04), here is a solution that worked for me. ubuntu 18.04 on virtualbox with 3D acceleration (on windows 10 host). Step to reproduce :

  1. install virtualbox 5.2.8
  2. install ubuntu 18.04 from official CD image (I choose the minimal install at startup)
  3. install build-essential and ubuntu-unity-desktop
  4. reboot
  5. install virtualbox guest extension from the virtualbox menu (not the apt-get version, maybe it works, did not test it).
  6. reboot
  7. ????
  8. Profit !

I don't know if it worked this time because I installed unity before the guest extension or because I use the guest extension provided by virtualbox and not from the repo.

It would seem it works with unity because unity does not use X11 and virtualbox does not support X11 very well ? (not sure about that part though, lots of other thread read, I might be a bit confused)

0

I am having the exact same issue as OP. I did a fresh install of Ubuntu 18.04 on the latest version of Virtualbox with 3D enabled and installed the latest version on guest utilities today 5/28, No smooth animations at all. glxinfo does show as yes for Direct rendering.

one workaround I found is that switching to Wayland Gnome on login works and animations work in Vbox, but it's definitely not as smooth as what I can get from the free VMware player, after using VMware player, I'm starting to like it more compared to VBOX and even thinking about purchasing a license.

From what I have seen, VMware provides better 3D support so I installed Ubuntu 18.04 on VMWare player free version with 3D enabled and all default animation work out of the box, gnome is smooth working as it should. I don't know how to report this as a bug but it is definitely a bug in Vbox 3D - Ubuntu 18.04 don't know if its a vbox issue or an ubuntu issue.

0

Virtualbox supports virtualization provider. One of them is KVM. You could change it in Virtualbox Settings.

Please check Virtualbox documentation about Paravirtualization providers. This may solve 3D Acceleration problem including window dragging. I had problem same as yours.

Optionally, turn on Paravirtualized Network (virtio-io) adapter to leverage KVM benefit.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.