8

In Ubuntu 18.04, using Gnome Tweak tool there's a way to disable the Activities hot corner. I have a multi-monitor setup, so having this feature on is extremely annoying. Anyway... After a couple of minutes (sometimes just seconds) the corner seems to re-enable itself. I check on the setting on Gnome Tweak and it's indeed disable. Here's a gif of the situation:

enter image description here

It seems that the problem happens after gnome-shell is restarted. Seems like this might be a bug, which if confirmed I will report it.

Any ideas on how can I prevent this from happening?

4
  • Try to disable it forcefully using an extension (see this: askubuntu.com/q/984705/480481).
    – pomsky
    May 8, 2018 at 20:12
  • Oh, sorry, I forgot to mention that I have used a couple of extension and I still get the same behavior
    – Felipe
    May 9, 2018 at 1:45
  • May it have connection with this message? imgur.com/a/yjyrukk Mar 18, 2019 at 13:53
  • I've got this behaviour as well. Very strange. Seems to re-activate every few hours
    – Addison
    Jun 7, 2019 at 1:49

1 Answer 1

1

It appears that the Dash to Panel extension also leaves this setting permanently enabled. If you are using this, you will have to pull a commit this is AFTER May 10th, 2019, or it will be broken. As of today, there has not been a release since March, so you'll have to build master yourself.


If this is happening to anyone who isn't using that extension, here is another solution: simply add a job to crontab to reset it every 5 minutes.

 */5 * * * * gsettings set org.gnome.shell enable-hot-corners false

Despite the value never actually being true, this will still cause the gnome shell to refresh, and remember your settings.

2

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.