19

I just installed ubuntu-desktop 18.04 on a new machine (no OS was previously installed). When I restart after installation completes the boot process gets stuck with

Started hold until boot finishes up.

Pressing Ctrl+Alt+F2 or F1 does not do anything.

When I go into the recovery screen, the keyboard does not respond... Any ideas how to deal with these issues? Thanks!

4

11 Answers 11

14

Had the same problem because the disks were full, I had to free up space If you think this might be the issue you can select the advanced boot in GRUB menu and use the terminal option to remove some of the files then restart and try login again.

To use the terminal option, in grub select advanced boot, then select recovery mode, and in the recovery menu select root.

7

In my case I got this message when my disk filled up with some Timeshift backup data. I found out it by running

du -a / | sort -n -r | head -n 20

Which is 1) calculates sizes for each and every folder on a disk 2) sort them in descending order 3) print the first 20 folders (means largest on a disk)

and then doing a rm -Rf on particular Timeshift folder. Not sure what would be your case but if it is a space matter - I recommend to remove couple of large folder/files and check if that helps.

7

Here is the complete process of resolving this issue:

  1. On the booting window, select the advanced option for Ubuntu to enter into the recovery mode.
  2. Once you are on the recovery mode, select the root option to enter into a terminal environment.
  3. Press Enter, then change the directory to the following location: cd /home/user_name/Downloads.
  4. Enter du -s * | sort -nr | head -n10 to list top 10 largest directories.
  5. Glance at the short list and enter rm -r .\name_of_file_to_be_removed.
  6. Ctrl+d to return to the recovery mode, then resume the normal boot.
1
  • Thank you ... you saved my files
    – Thanga
    Feb 16 at 12:55
2

I also faced this problem.this because of memory will be full in your system. Clear some memory for it you will solved with the problem. Key board will not word at this time. So please turn off your computer. Open advanced option for Ubuntu during start up and clean the system, and clear the swap using the below mentioned commands ( https://www.google.com/amp/s/www.tecmint.com/clear-ram-memory-cache-buffer-and-swap-space-on-linux/amp/ )

1
  • Link only answers become obsolete if content on link change or link is dead. Please import relevant part of the article attached and citing the source.
    – Kulfy
    May 7, 2019 at 7:38
1

On power up, can you press ESC or DEL or whatever key sequence gets you into the boot manager? I upgraded a LattePanda running lubuntu 16.04 to 18.04, and it was looping through some failure sequence. When I pressed ESC and entered the boot manager, I found that the first item in the boot sequence was an entry for Android. I don't have Android installed on this device, so I don't know how or why that entry was there. I selected the override to boot ubuntu, which worked fine. Once in the ubuntu O/S, I entered the following, based on info I found in another post:

sudo modprobe efivars

followed by:

efibootmgr

which told me that the Android entry was #5, so I then entered:

sudo efibootmgr -b 5 -B

to remove that entry from the boot sequence so that the next time I powered off and back on, it went to ubuntu. Hope this helps.

1

This happens when you don't Unmount your external device and remove it . Use the above method press Ctrl+Alt+F2 orF1 enter Username and Password. Now Using terminal type

sudo modprobe efivars 

and then followed by

efibootmgr 

You will see the boot sequence order look for external device's now type

sudo efibootmgr -b no -B 

Note no:denotes the external device's number.This worked for me.

1
  • 1
    "EFI variables are not supported on this system."
    – Alex Ryan
    May 2, 2019 at 18:06
0

I had the same issue on boot after upgrading Kubuntu 16.04 to 18.04. I also saw error messages about lightdm failing to start. Here's what I did to fix the issue.

In the grub bootloader, edited the boot entry and removed the following variables from the linux boot command:

quiet splash $vt_handoff

Then press F10 to boot. It was now able to boot to a tty1 console login.

I first tried to install the latest nvidia drivers for my graphics card. This didn't help. I got the same error on reboot. (But keeping this here in case it was important https://linuxconfig.org/how-to-install-the-nvidia-drivers-on-ubuntu-18-04-bionic-beaver-linux )

Next I changed the display manager.

sudo dpkg-reconfigure lightdm

I changed the display manager to sddm (the only other option). Then I started sddm and the graphical interface started up.

sudo service sddm start

So it appears it was an issue with lightdm.

0

"reboot", press "f8", select "advanced > Recovery Startup" > check your "/var/log/.." Boot related Logs for any Units/Services/Daemons Startup-Errors. You can also hit "Strg+Alt+F7" during Bootsequence to see whats going on, (or whatever [v]irtual[T]erminal is configured for your Session in "Grub.config" > Startoptions="nosplash quiet $vt_handoff=7".

0

in my case i ran out of memory, because i had some snapd snapshots that ate all my memory(spotify). I went to /var/lib/snapd/snapshots and removed those files that were up to 50GB of memory

0

The issue for me was i had an external USB device plugged. Once unplugging the USB device and restarting, the system booted extremely fast with no issues.

0

In my case i ran out of memory in ubuntu 18.04, because my system didn't have enough memory to boot.Note that your system needs at least 15gb of free memory to boot. There are two ways to delete unnecessary files.

solutions

1.Try to boot in recovery mode to solve out of memory problem

  • press Ctrl+Alt+F2 orF1 to enter recovery mode
  • Once you are on the recovery mode, select the root option to enter into a terminal environment.
  • Press Enter, then change the directory to the following location: cd /home/user_name/folder_name where you want to delete unnecessary file.
  • Enter du -s * | sort -nr | head -n10 to list top 10 largest files of current directories.
  • Review shortlisted items to be deleted and enter rm -r .\name_of_file_to_be_removed.
  • Ctrl + d to return to the recovery mode, then boot normally.

2. Try to boot your system using bootable pen-drive which contain iso file of ubuntu of same version

  • Boot into your system using pen-drive
  • select try ubuntu option
  • click on files in menu bar located at left side of screen
  • click on + other locations option located at left-buttom
  • You will see list of disk. select disk which has path /dev/sda .you can find path at right end of disk details
  • Click on above disk then you can navigate either home or desktop and then browse your folders and delete unnecessary file
  • you can't delete file as usual you need to open terminal at folder and delete files using command
    rm -r name_of_file_to_be_removed.
  • Now you can shut-down your system and then remove pen-drive and boot normally

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.