8

I just installed ubuntu-desktop 18.04 on a new machine (no OS was previously installed). When I restart after installation completes the boot process gets stuck with

Started hold until boot finishes up.

Pressing Ctrl+Alt+F2 or F1 does not do anything.

When I go into the recovery screen, the keyboard does not respond... Any ideas how to deal with these issues? Thanks!

3

Had the same problem because the disks were full, I had to free up space If you think this might be the issue you can select the advanced boot in GRUB menu and use the terminal option to remove some of the files then restart and try login again.

To use the terminal option, in grub select advanced boot, then select recovery mode, and in the recovery menu select root.

2

I also faced this problem.this because of memory will be full in your system. Clear some memory for it you will solved with the problem. Key board will not word at this time. So please turn off your computer. Open advanced option for Ubuntu during start up and clean the system, and clear the swap using the below mentioned commands ( https://www.google.com/amp/s/www.tecmint.com/clear-ram-memory-cache-buffer-and-swap-space-on-linux/amp/ )

  • Link only answers become obsolete if content on link change or link is dead. Please import relevant part of the article attached and citing the source. – Kulfy May 7 '19 at 7:38
2

In my case I got this message when my disk filled up with some Timeshift backup data. I found out it by running

du -a / | sort -n -r | head -n 20

Which is 1) calculates sizes for each and every folder on a disk 2) sort them in descending order 3) print the first 20 folders (means largest on a disk)

and then doing a rm -Rf on particular Timeshift folder. Not sure what would be your case but if it is a space matter - I recommend to remove couple of large folder/files and check if that helps.

1

On power up, can you press ESC or DEL or whatever key sequence gets you into the boot manager? I upgraded a LattePanda running lubuntu 16.04 to 18.04, and it was looping through some failure sequence. When I pressed ESC and entered the boot manager, I found that the first item in the boot sequence was an entry for Android. I don't have Android installed on this device, so I don't know how or why that entry was there. I selected the override to boot ubuntu, which worked fine. Once in the ubuntu O/S, I entered the following, based on info I found in another post:

sudo modprobe efivars

followed by:

efibootmgr

which told me that the Android entry was #5, so I then entered:

sudo efibootmgr -b 5 -B

to remove that entry from the boot sequence so that the next time I powered off and back on, it went to ubuntu. Hope this helps.

1

This happens when you don't Unmount your external device and remove it . Use the above method press Ctrl+Alt+F2 orF1 enter Username and Password. Now Using terminal type

sudo modprobe efivars 

and then followed by

efibootmgr 

You will see the boot sequence order look for external device's now type

sudo efibootmgr -b no -B 

Note no:denotes the external device's number.This worked for me.

  • 1
    "EFI variables are not supported on this system." – Alex Ryan May 2 '19 at 18:06
0

I had the same issue on boot after upgrading Kubuntu 16.04 to 18.04. I also saw error messages about lightdm failing to start. Here's what I did to fix the issue.

In the grub bootloader, edited the boot entry and removed the following variables from the linux boot command:

quiet splash $vt_handoff

Then press F10 to boot. It was now able to boot to a tty1 console login.

I first tried to install the latest nvidia drivers for my graphics card. This didn't help. I got the same error on reboot. (But keeping this here in case it was important https://linuxconfig.org/how-to-install-the-nvidia-drivers-on-ubuntu-18-04-bionic-beaver-linux )

Next I changed the display manager.

sudo dpkg-reconfigure lightdm

I changed the display manager to sddm (the only other option). Then I started sddm and the graphical interface started up.

sudo service sddm start

So it appears it was an issue with lightdm.

0

"reboot", press "f8", select "advanced > Recovery Startup" > check your "/var/log/.." Boot related Logs for any Units/Services/Daemons Startup-Errors. You can also hit "Strg+Alt+F7" during Bootsequence to see whats going on, (or whatever [v]irtual[T]erminal is configured for your Session in "Grub.config" > Startoptions="nosplash quiet $vt_handoff=7".

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.