3

After upgrading to Ubuntu 18.04 from Ubuntu 17.10, I am unable to view some encapsulated postscript images (EPS) that use Arial font.

I can view some images with with Arial font, but not all. I'm not sure what the pattern is. For ones that I cannot view, I get weird random characters and boxes when I view them with ghostview (gv).

I have installed the ttf-mscorefonts-installer package. In fact, I was trying to insert Arial fonts into graphs generated by R according to these instructions. For a few days, I thought I had this wrong but others were able to see the Arial fonts inserted by my system... So, my system can insert Arial font into images, but it cannot view some of them.

If I take the EPS files that I cannot view and then convert them to pdf using ps2pdf, I am able to view the PDF file using okular.

Lastly, as expected, if I go into the menu and run the "Font Management" program, then Arial and Arial Black both appear in that list.

Would someone have an idea of what I'm missing? It feels like there is something specific to ghostview (or ghostscript) but I don't know what it is.

0

I solved my problem, but somewhat by accident.

I stumbled on a fairly long exchange that talks about some kind of conflict between ttf-mscorefonts-installer and ghostscript.

My problem doesn't seem exactly like the one described here, but as I'm out of ideas, I decided to just remove this package... And then everything worked. That is, my EPS files generated using R can display fine again.

So, I guess that is the problem -- as I don't have a need for this package (I presume this means a substitute for the Arial font is being found), I can leave this as-is.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.