24

Is it possible to disable keyboard shortcut overlay in Ubuntu 12.04?

  • One reason to disable this, or to delay the appearance of the shortcut key overlay, is that it interferes with taking screen captures with the easy screen capture function normally launched by <Super>Button 1. The hints in the overlay appear in the screen capture, which is usually not what you want. – user79495 Jul 26 '12 at 18:16
  • I'm not using 12.10 but as far as I know this option has not been removed. You can try reseting your compiz/unity settings with $ compiz.reset, logout and login then execute $ dconf write /org/compiz/profiles/unity/plugins/unityshell/shortcut-overlay false. – Jesse Apr 4 '13 at 2:13
16

For Ubuntu 12.04 and below:

The keyboard shortcut overlay is controlled by an option in the compiz unity plugin.

enter image description here

In the experimental tab of ccsm you can untick the option shown.

Remember the use of CCSM is strongly discouraged - you can achieve the same via gconf-editor

enter image description here

untick the option shown in the path /apps/compiz-1/plugins/unityshell/screen0/options/shortcut_overlay

  • 3
    On my fresh 12.10 install, /apps/compiz-1/plugins/unityshell is not present. – Bart van Heukelom Nov 14 '12 at 19:59
  • Why is using gconf-editor preferred over using ccsm ? – Kristopher Ives Jan 22 '13 at 22:41
  • 1
    @KristopherIves - this Q&A will explain your question: askubuntu.com/questions/80589/… – fossfreedom Jan 22 '13 at 23:16
  • 1
    On my fairly fresh 14.04 installation, /apps/compiz-1/plugins/unityshell is also not present. – Tom Swirly Jul 19 '14 at 19:13
  • /apps/compiz-1/plugins/unityshell is not present on 16.04.1 either – anon58192932 Oct 12 '16 at 2:43
7

For those like me that prefer the command line:

Ubuntu 12.10+:

(Tested up to 16.04)

dconf write /org/compiz/profiles/unity/plugins/unityshell/shortcut-overlay false

Ubuntu 12.04 and below:

sudo apt-get install gconf-editor
gconftool-2 --set /apps/compiz-1/plugins/unityshell/screen0/options/shortcut_overlay --type bool false
5

For Ubuntu 12.10:

You can disable this behavior following this steps:

  1. Install Ubuntu Tweak Install-It
  2. Open the label Tweaks and choice Unity

    screenshoot

  3. Now you have to look at the second option called Shortcuts hints overlay

    screenshoot2

  4. Now click at the box to turn this feature off, so this remains as this:

    screenshoot3

  • 1
    Out of curiosity, how would this be done on the command line? – Kupiakos Apr 11 '13 at 20:17
  • I have no idea if this is changing some specific option in the gconf schema. If so, there should be – Lucio Sep 7 '13 at 21:44
0

I know this is an old thread, but dconf solution doesn't work any more, at least as of 16.04 (and maybe earlier as well).

For 16.04+, the easiest way is to get Unity Tweak Tool, And go to Overview->Additional, and uncheck "Hold Super for keyboard shortcuts"

  • Odd, I just tested my solution in 16.04 and it worked fine. – bmaupin Dec 15 '16 at 21:03
0

These answers don't work for me at all, and Ubuntu Tweak won't really help, because this is a per-user setting, and by the time you open Ubuntu Tweak, you've already exited this first-time popup (it exits on the first mouse/keyboard event). So what's the point of disabling a popup that's already disabled itself? This setting only makes sense for new users.

I've tried several dconf/gsettings/whatever answers, none could set it successfully. I tried

gsettings set org.compiz.unityshell:/ shortcut-overlay false

And also via /usr/share/compiz/unityshell.xml, but nope, it won't work. Apparently this popup shows up if the .config/unity/first_run.stamp file doesn't exist. So you can:

mkdir -p /etc/skel/.config/unity
touch /etc/skel/.config/unity/first_run.stamp

This way new users will have this file at first sign-in and won't see the damn popup.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.