I installed Ubuntu 18.04 from a bootable USB last night, but when I tried to login to the operating system I got stuck at a ubuntu loading screen with five dots on it.

enter image description here

I have seen an older question where it might seem to be a graphics problem, and the solution mentioned was to press Ctrl +Alt+f1,f2,f3 etc. to go the shell, but when I do that the shell is not showing up.

What else can I try?

  • 2
    If you press escape, can you see anything? If you hard reset (using the power button), and then boot in non-quiet mode by editing the selected item (press e), removing quiet splash and pressing ctrl-x, is anything interesting displayed on screen?
    – Iain Lane
    May 8, 2018 at 12:21
  • I did it like you said but still it is stuck on loading.
    – Wasil Khan
    May 8, 2018 at 14:14
  • I didn't expect it to fix the problem. It should make some text be displayed and that text might contain a clue.
    – Iain Lane
    May 8, 2018 at 16:01
  • It didn't give any error but after deleting quiet splash from the grub menu it runs quiet well in the recovery mode. What do you suspect? What should I do now?
    – Wasil Khan
    May 8, 2018 at 16:14
  • You mean it made the computer boot? Perhaps if you run journalctl you can see evidence of a problem?
    – Iain Lane
    May 10, 2018 at 15:39

7 Answers 7


Ubuntu 18.04 uses Wayland display server which does not work on a few systems.

Try the below steps to make the system boot normally:

  1. Go to recovery mode from the GRUB menu and then boot into the system. Recovery mode uses low graphics and hence will not get stuck at the splash (logo) screen.
  2. Once you are logged in, open a terminal (Use Ctrl+Alt+t shortcut)
  3. Try changing the display server to Xorg in the gdm3 custom conf file using the below command and reboot the system.

    sudo gedit /etc/gdm3/custom.conf
  4. Change #WaylandEnable=false to WaylandEnable=false (Basically uncommenting it).

  5. Reboot the system.

This will disable the Wayland display server and make the system to use the Xorg display server. Your system should hopefully progress to the login screen now with a normal boot.

Let me know if this works.

Reference: https://linuxconfig.org/how-to-disable-wayland-and-enable-xorg-display-server-on-ubuntu-18-04-bionic-beaver-linux

  • 2
    Thanks, It worked for me. i logged in as root in recovery mode, edited /etc/gdm3/custom.conf and modified WaylandEnable=false, using vi editor. Rebooted the system.
    – Siva Anand
    Sep 17, 2019 at 6:49
  • 1
    I can now stop smacking my head on the table. thank you a million.
    – David
    Jun 8, 2020 at 16:56
  • 1
    It did not work for me unfortunately. I am on ubuntu 18.04 and I have a Dell Latitude. The kernel versions I have available in GRUB are: - 5.4.0-42-generic - 5.3.0-62-generic
    – desmond13
    Aug 14, 2020 at 10:24
  • 1
    I'm so stuck... this nor anything else I've tried has not helped. Jan 18, 2021 at 15:40

The similar stuck issue occurs when I try to restart or shutdown the system after a new installation of ubuntu 18.04.2 on my laptop.

I solved the problem by switch from Nouveau driver to Nvidia driver, using Software & Updates App, as following screenshot. The problem disappers after using Nvidia driver, so I assume there are some potential bugs in Nouveau driver.

enter image description here

Just for references, here is my video card info:

$ ubuntu-drivers devices
== /sys/devices/pci0000:00/0000:00:1c.0/0000:01:00.0 ==
modalias : pci:v000010DEd00001D12sv00001D72sd00001604bc03sc02i00
vendor   : NVIDIA Corporation
driver   : nvidia-driver-390 - distro non-free recommended
driver   : xserver-xorg-video-nouveau - distro free builtin

$ sudo lshw -c video
# OR
$ sudo lshw -c display
       description: VGA compatible controller
       product: HD Graphics 620
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 02
       width: 64 bits
       clock: 33MHz
       capabilities: pciexpress msi pm vga_controller bus_master cap_list rom
       configuration: driver=i915 latency=0
       resources: irq:128 memory:b2000000-b2ffffff memory:c0000000-cfffffff ioport:4000(size=64) memory:c0000-dffff
       description: 3D controller
       product: GP108M [GeForce MX150]
       vendor: NVIDIA Corporation
       physical id: 0
       bus info: pci@0000:01:00.0
       version: a1
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list
       configuration: driver=nvidia latency=0
       resources: irq:133 memory:b3000000-b3ffffff memory:a0000000-afffffff memory:b0000000-b1ffffff ioport:3000(size=128)

For the issue of stucking in the Background or Lock Screen, I have tried the way to complete the task.

1. Give the command

$ sudo gedit /etc/default/grub

2. Add nomodeset

Modify the following line


to the the new one.

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset"

3. Save and Exit




I was also facing similar problem. Using nomodeset I can boot into the system but now I solved the problem another way round. Only thing we need to do is to upgrade or downgrade the kernel version. https://askubuntu.com/a/1014753 This forum has explained how to access advanced option in Ubuntu. Now when we enter into advanced option we can see Linux kernel versions like:

enter image description here

  • Now navigate to the lower version of kernel using arrow keys but leave all the recovery modes kernels.
  • Leaving the recovery modes kernel, select the lowest version of kernel and hit enter.
  • Now it will boot normally without using nomodeset. Remove nomodeset before if you have written it in grub file and update the grub.
  • Now to make changes permanent go through this below given link and remove all the above kernels but don't remove the running kernels.

https://itsfoss.com/upgrade-linux-kernel-ubuntu/ This link will guide us through the procedure to update or downgrade the kernel. For me kernel 5.3 worked perfectly.


I just had it stuck at the next screen when it should show the login prompt - it just showed a solid wine coloured screen (with a subtle Ubuntu at the bottom).

I was using a virtual machine (VirtualBox) and the fix was to change the Display setting from VMSVGA to VBoxSVGA. Phew!

Edit: Changed to VboxVGA because VBoxSVGA caused hideous total slowdown of guest VM (possibly related to 4k screens or VirtualBox 6.0 - didn't look into it).


I check the Ubuntu 18.04 system. With regard to the Deep Learning scenario such as RTX 2070 Super,the Nvidia Graphics driver has been set to Nvidia-driver-440(open source). It indicates the ppa version. In addition, the setting of WaylandEnable=false is still there.

The question is that it happens sometimes for the Ubuntu 18.04 to randomly stuck in the default Background,Lock Screen or the black screen with the message of /dev/sda2:clean...

With regard to the issue /dev/sda2:clean..., it seems to be the fsck check while Ubuntu 18.04 executes ~30th boot.

Please have a look at the following answer quote.

The message you are seeing is only a result of a fsck or file-system check, which tells you it didn't detect errors (ie. clean) & how many files & blocks it checked. fsck gets run ~30th boot, unless a problem was detected such as a improper shutdown the time before (eg. power-button was used to force shutdown instead of command via sysrq combination etc). The message you are seeing is not a problem, it's a consequence of something done last time it was booted; otherwise your screen is 'black' from your description, i.e. you have a 'black' screen issue. – guiverc Jan 26 at 11:06

I will be pleased to share my findings in the future.

Nvidia sets a higher bar for the graphics card of RTX 20XX Super. Only higher version of CUDA Driver such as Nvidia-Driver-440 can be allowed for the above-mentioned graphics card. For the older graphic cards such as RTX 2060 with Nidia-430-Driver, Ubuntu 18.04 has no such problem.

Therefore,it is probably the compatibility issue between the newer Nvidia Graphics and Ubuntu 18.04. In addition, Nvidia does not support for the higher version Ubuntu such as Ubuntu 19.04 and Ubuntu 20.04.

If any one has better ideas, please feel free to share.


With regard to the issue \dev\sda2... : clean..., it seems to be the bug of the fsck check while Ubuntu 18.04 LTS with regard to the second scenario as follows.

There are two scenarios, one is that the system go across the the black screen \dev\sda2..., and another scenario is that the system stuck in the black screen.

For the second scenario, I list the new solution to modify file system parameter as follows.

$ sudo tune2fs -c 60 -i 30 /dev/sda2

60 means 60 times turn-on limitation and 30 means 30 days. Either the turn-on times arrives up to 60 times or 30 days, Ubuntu 18.04 will have the fsck--file system check. It seems to be fair to developers.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.