13

This appears to be a fairly common issue but the solutions I tried have not worked. Using nvidia-340.106

Solutions I tried:

  1. compizconfig-settings-manager Force full screen redraws (buffer swap) on repaint

  2. Updating /etc/X11/xorg.conf to add (Option "FlatPanelProperties" "Dithering=Disabled")

  3. Enable triple buffering in xorg.conf

  4. Using nvidia-settings to enable Sync to Vblank, Allow Flipping, Use Conformant Texture Clamping

  5. Use KDE and GNOME

lspci output:

03:00.0 VGA compatible controller: NVIDIA Corporation MCP7A [GeForce 9400] (rev b1) (prog-if 00 [VGA controller])
    Subsystem: Apple Inc. MCP7A [GeForce 9400]
    Flags: bus master, fast devsel, latency 0, IRQ 26
    Memory at d2000000 (32-bit, non-prefetchable) [size=16M]
    Memory at c0000000 (64-bit, prefetchable) [size=256M]
    Memory at d0000000 (64-bit, prefetchable) [size=32M]
    I/O ports at 1000 [size=128]
    [virtual] Expansion ROM at d3000000 [disabled] [size=128K]
    Capabilities: <access denied>
    Kernel driver in use: nvidia
    Kernel modules: nvidiafb, nouveau, nvidia

lshw output:

  *-display                 
   description: VGA compatible controller
   product: MCP7A [GeForce 9400]
   vendor: NVIDIA Corporation
   physical id: 0
   bus info: pci@0000:03:00.0
   version: b1
   width: 64 bits
   clock: 33MHz
   capabilities: pm msi vga_controller bus_master cap_list rom
   configuration: driver=nvidia latency=0
   resources: irq:26 memory:d2000000-d2ffffff memory:c0000000-cfffffff memory:d0000000-d1ffffff ioport:1000(size=128) memory:d3000000-d301ffff
1
  • You can use nvidia-smi to see if nvidia is running gnome-shell on 17.04+
    – Jonathan
    Jun 4 '18 at 23:51
12

I had the same issue and this is what worked for me I started following this article How to install the NVIDIA drivers on Ubuntu 18.04 Bionic Beaver Linux

In a nutshell I listed the recommended drivers using

$ ubuntu-drivers devices

then to install the recommended drivers

$ sudo ubuntu-drivers autoinstall

or you can use apt to install whicheve driver you prefer if it is not the recommended one

$ sudo apt install nvidia-390

once I rebooted my system I was good to go but if you still have problems a few other things are mentioned in the article one being disabling Noveau Nvidia driver How to disable Nouveau nvidia driver on Ubuntu 18.04 Bionic Beaver Linux To summarize you blacklist the Nvidia nouveau driver:

$ sudo bash -c "echo blacklist nouveau > /etc/modprobe.d/blacklist-nvidia-nouveau.conf"
$ sudo bash -c "echo options nouveau modeset=0 >> /etc/modprobe.d/blacklist-nvidia-nouveau.conf"

and then you can confirm the content of the new modprobe config file:

$ cat /etc/modprobe.d/blacklist-nvidia-nouveau.conf

you should see something like

blacklist nouveau
options nouveau modeset=0
4
  • 2
    That didn't work for me, still the same flickering.
    – chaNcharge
    Jun 11 '18 at 23:19
  • That didn't work for me either Jun 28 '18 at 5:19
  • 1
    This worked for me. Nov 29 '18 at 14:51
  • Worked for me - ASUS FX505DT, Ryzen 5-3550H with NVIDIA GeForce GTX1650 GDDR5 4GB VRAM Graphics. I didn't have to blacklist nouveau. (Running Ubuntu 18.04).
    – rkrishnan
    Dec 9 '19 at 14:39
3

Basically among other things simply, read Post 5 for the none specific version.

Run this

sudo -H gedit /etc/modprobe.d/nvidia-drm-nomodeset.conf

Add this line

options nvidia-drm modeset=1

Link to Source

6
  • 1
    Instead of sudo gedit use sudo -H gedit which is safer. Jun 23 '18 at 21:01
  • That doesn't seem to work for me either, so I've stuck to using the nouveau drivers. Is there a step I'm missing?
    – chaNcharge
    Sep 16 '18 at 6:37
  • Had this issue with nvidia 410. Upgrade to 415 Followed steps to blacklist nouveau. Finally the options nvidia-drm modeset=1 solved. Jan 10 '19 at 3:37
  • This broke my desktop, had to log in with the shell and comment the line. Aug 5 '19 at 17:17
  • 2
    Can anyone explain to me what this actually does? Feb 14 '20 at 10:48
0

I'm posting here as this was one of the many resources I accessed when trying to resolve an issue with a fresh install of Ubuntu on a system with an Nvidia graphics card that had a screen that blinked on and off and also had rendering issues with fuzzy edges of the screen and such.

Check your CABLE. I was setting up a brand new 4k monitor with a nvidia card that had a mini display port output. I bought a cable that ran from mini display to HDMI when I was buying all the gear from the PC store. I've had issues with cables in the past, but saw 4k printed on the side of the cable and thought I was good. After two solid days of installs, reinstalls, root prompts and general swearing - I started to troubleshoot rather than trying to software troubleshoot. That cable on a standard HD screen worked fine. I then swapped the cable to a mini display port to display port adapter, and also worked fine. All the issues that I was finding, which were exactly like those described here were down to a cable that didn't support the data transfer that was needed for this monitor.

After then further testing (yet another install) I found that the card (NVidia Quardo P1000) did in fact work out of the box with the Nouveau driver, I stil updated to the newest "Tested" Nvidia drivers and did notice an improvement when playing 4k videos in terms of choppiness and display artefacts. But that driver upgrade was also seamless and without issue.

tl'dr: If you are using anything higher than 1920x1080 resolution, check your cable. If you're trying to use even that resolution over an old cable/connection and you can't seem to resolve it. Try a new cable. You might save yourself endless unsolvable issues.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.