I just upgraded to 18.04, and I noticed that the sound from my headphones, whether plugged into front or back port, was very crackling and slow/delayed. This issue didn't exist on 17.04/10. It also doesn't affect audio coming from HDMI via Radeon 560 GPU, just the headphone/onboard audio. The relevant device is:

00:1f.3 Audio device: Intel Corporation Sunrise Point-H HD Audio (rev 31)  

I tried a bunch of fixes for pulseaudio I found googling, including this one and this one. Neither of which helped.

I have found something that at least makes it listenable - changing "default-fragment-size-msec" from 25 to 5 in /etc/pulse/daemon.conf. It makes it much much better, but still a little crackly from time to time.

I've googled for 30 min or more now, and not finding anything else that seems recent and relevant, so wondering if I should maybe open a bug, or if there's something I'm overlooking here.


I had the same issue and killing pulseaudio fixed it for me. I'm not sure why it would get into a bad state, but restarting pulseaudio might be something to try.


killall pulseaudio
  • This is some dark magic. Any idea on what's actually going on? (this works though, I think may be connected to suspend-awake process) – jave.web Jan 7 at 16:55

I had the same problem. It seems related to speech-dispatcher (some text-to-speech utility).
try :

killall speech-dispatcher

If the sound comes back to normal you can remove it completely (if you don't need it) with :

sudo apt-get remove speech-dispatcher
  • 2
    This solved the issue for me on Debian Buster. In my case it was only needed as dependency of orca which I don't use. – lifeofguenter Jun 20 '19 at 17:30
  • Same as lifeofguenter – TheFiddlerWins Jul 18 '19 at 23:19
  • 1
    this fixed it for me, ubuntu 20.04/pop!os 20.04 – Tim Richardson Aug 23 '20 at 6:16
  • this solved my problem on ubuntu 20.04 – csenga Sep 28 '20 at 14:58
  • Yup, that was it. The bug would present when my audio output was switching. – ppetraki Jan 29 at 17:13

Press Ctrl+Alt+T to go to a terminal and use your favourite editor to edit the file

nano /etc/pulse/default.pa

then find a line containing:

load-module module-udev-detect

modify this to become:

load-module module-udev-detect tsched=0

save and exit and you're all set!

  • 3
    you need to restart your laptop or run: pulseaudio -k after you change the configuration. – stason Nov 16 '18 at 3:05
  • all it does is makes the sound completely distorted – Display Name Nov 16 '18 at 13:12
  • 1
    This is the solution and it should be the accepted answer -- although it would be good to edit it and add the pulseaudio -k command – Merc Feb 15 '19 at 8:59
  • 4
    An explanation about what exactly this does would be helpful. It can be found at this Ask Ubuntu question – polynomial_donut Jun 4 '19 at 19:09
  • actually, on a newer ubuntu version this actually works. – Display Name Nov 1 '19 at 11:33

I ran into the same issue (crackling sound) today on Ubuntu 18.10 on my Intel NUC Canyon Hades.

killall pulseaudio

only fixed it temporarily for some reason. After a few minutes the problem was back again.

What ultimately did the trick was the answer posted by Fabby in combination with the comment by statson to enter

pulseaudio -k
  • I think when you kill PulseAudio, the OS falls back to ALSA. Most likely your PulseAudio has some configuration issues. – user31389 Dec 15 '19 at 14:17

If you have Firefox or Chrome open when the sound starts distorting. Shut them browsers down and test the sound again. If it has stopped, then you need to use a different web browser. I installed Vivaldi yesterday and I haven't had a problem since. There are many browsers to choose from.

Not the answer you're looking for? Browse other questions tagged or ask your own question.