I am running Ubuntu 16.04 and Firefox freezes my system about once a day. I know it is Firefox because my system works fine with Chrome. The same freezes occurred when running Firefox from live USB versions of Ubuntu 16.04 and 17.10. When frozen, the keyboard and mouse are unresponsive, and various Ctrl+Alt+ and Alt+SysRq+ combinations (commands on this page for example) don't seem to do anything. I end up having to hard reboot by holding the power button.

I am not a Linux expert, but my understanding is that at this point I should check /var/log/syslog, /var/log/kern.log, and similar files. I have checked the contents of these files, have web-searched the messages, but don't know enough to have any meaningful insights. So what should I do next?

If it helps, below is the end of my /var/log/syslog prior to the crash. And I would be happy to update my post with any more info.

May  7 16:28:41 MyComputer dbus[848]: [system] Activating via systemd: service name='org.freedesktop.nm_dispatcher' unit='dbus-org.freedesktop.nm-dispatcher.service'
May  7 16:28:41 MyComputer NetworkManager[876]: <info>  [1525735721.7446]   server identifier
May  7 16:28:41 MyComputer NetworkManager[876]: <info>  [1525735721.7446]   lease time 300
May  7 16:28:41 MyComputer NetworkManager[876]: <info>  [1525735721.7446]   nameserver ''
May  7 16:28:41 MyComputer NetworkManager[876]: <info>  [1525735721.7446]   nameserver ''
May  7 16:28:41 MyComputer NetworkManager[876]: <info>  [1525735721.7446]   domain name 'lan'
May  7 16:28:41 MyComputer NetworkManager[876]: <info>  [1525735721.7446] dhcp4 (wlp5s0): state changed bound -> bound
May  7 16:28:41 MyComputer systemd[1]: Starting Network Manager Script Dispatcher Service...
May  7 16:28:41 MyComputer dhclient[1352]: bound to -- renewal in 139 seconds.
May  7 16:28:41 MyComputer dbus[848]: [system] Successfully activated service 'org.freedesktop.nm_dispatcher'
May  7 16:28:41 MyComputer systemd[1]: Started Network Manager Script Dispatcher Service.
May  7 16:28:41 MyComputer nm-dispatcher: req:1 'dhcp4-change' [wlp5s0]: new request (1 scripts)
May  7 16:28:41 MyComputer nm-dispatcher: req:1 'dhcp4-change' [wlp5s0]: start running ordered scripts...
May  7 16:29:53 MyComputer wpa_supplicant[1118]: nl80211: send_and_recv->nl_recvmsgs failed: -33

update 1 (May 21 2018)

I am still getting freezes when I run Firefox from a terminal in safe mode with my profile path set to an empty directory (a step suggested by @dsstorefile1):

firefox -safe-mode -profile ~/some_empty_directory/ -no-remote -new-instance

I also ran debsums to check the checksums of the Firefox package, but it did not find any errors.

update 2

I installed Arch Linux on my machine and still got the same behavior. This means it is not a distribution-specific problem.

update 3

I upgraded by RAM, graphics card, and monitor. But the problem is still occurring.

update 4

I updated my BIOS, but the problem is still occurring.

  • @dsstorefile1 I haven't tried that. I will give it a shot and report back.
    – Trevor
    May 8, 2018 at 4:45
  • What version of firefox? ... is it up to date? ... if not, you should upgrade it ... with old version, when it starts to slow down, this can help [ about:memory ] then hit 'clear memory' ...
    – cmak.fr
    May 22, 2018 at 7:50
  • @cmak.fr My Firefox installation is up to date (version 60.0.1 as of today).
    – Trevor
    May 22, 2018 at 20:09

5 Answers 5


I had a similar problem. It is weird, but when I deleted the browser history (more than 2 GiB data) the problem went away and has not come back.

I know it sounds crazy but it helped me. I am not sure if it helps you, but I am sharing solution that which solved problem with Ubuntu freezing while using Firefox.

  • 1
    apparently it helped. Also about 10s after starting firefox it was crashing all extra gnome extensions I installed, and til now extensions have not crashed! I had to ctrl+H and press DEL on each month entries to delete them, while doing that firefox froze again about 3 times btw. They could improve the history, it is clearly broken. Ubuntu 20.04, firefox 81.
    – VeganEye
    Oct 4, 2020 at 4:34

I have had this problem with Firefox for a long time, and it is not affected by updates to either Firefox or Ubuntu. It appears to be because Firefox does not release memory once it has taken it, so that every page you have loaded up stays in memory.

As far as I know there are only two ways of dealing with this problem:

  1. periodically close Firefox down and relaunch it, or
  2. don't use Firefox.

However, if anyone knows of a better solution that would be great.

  • 2
    That may be a problem that Firefox has, but I don't believe it is what's causing my freezes. For example, my most recent freeze happened after a fresh restart and I had only opened 3 pages.
    – Trevor
    Oct 2, 2018 at 4:39
  • @wxyz Actually, yes, I have occasionally had the problem after a fresh restart too, although most often a restart ends the problem. Clearly what I said is not the whole answer, and I would be very much interested if anyone could give more information.
    – Michael D
    Oct 20, 2018 at 19:31
  • 1
    It's late 2019, I'm running Ubuntu 19.04 and I would love to switch from Chrome to FF (especially given that we are on the verge of the Manifest V3 update which will spell trouble for Chrome adblockers) but.. there's a big but.. FF 70 has been causing TWO severe system freezes in the few days I've been using it.. Granted I'm using it to do web development so it might not be the easiest setup but still.. I've been horrified to discover that absolute OS freeze (of the kind requiring a hard reboot) were still even possible, with a modern OS.
    – cjauvin
    Dec 6, 2019 at 14:57
  • "don't use Firefox" is not an acceptable answer in this context. In my case, I thought that Firefox was faulty when it was the X server that was, as shown in the answer below. Sep 17, 2021 at 14:28

Same situation for me, on Ubuntu/Mate/Xfce 20.04.3 LTS. As soon as I opened a second Firefox window, the computer froze, even the clock froze. I just then had to wait 5, or even 10 minutes ... or reboot (Alt Syst b, thanks to Magic SysRq key).

I thought I had found a workaround for this problem: using Firefox ESR. As I use Firefox Sync to synchronize my passwords between my two other workstations (they also under Ubuntu, and without these problems on Firefox), I quickly found back my surfing environment on the internet.

But after a few hours, the freezing problem surfaced again, excluding the version of Firefox ... Actually, if the X server crashed, the rest of the machine was functioning normally, for example we could connect from a remote station. SoI therefore decided to change the graphics card driver, as explained in binary driver Nvidia.

And everything started to work normally !!!

Results of the operation: it is "simply" a problem with the graphics card driver which blocked my computer, and not Firefox.

my configuration: vendor : NVIDIA Corporation model : G84GL [Quadro FX 1700] driver : nvidia-340 - distro non-free recommended

I imagine there is an xserver-xorg-video-nouveau bug which makes it incompatible with Firefox.

Consequence: I reinstalled Firefox, standard version (92.0 (64-bit))!

hope it helps



With Ubuntu 22.04 (Sept/2022), I have found that when Firefox 105.0 was locking up,(So was 101 and 102) a simple "QUIT" and then "OPEN" in the Firefox icon on the taskbar would re-open Firefox AND all its tabs. Then, I saw somewhere a suggestion that clearing some of the oldest saved urls in "History" (Ctrl-Shift-H would fix this problem- start with getting rid of those items six months or older, and then work your way up.
It seems the History folder needs to be cleaned out periodically.

  • I'll consider this. For me, the tabs will not respond when I click to open a different one. Also I'm unable to close (one of many) tabs. Same thing happened with LibreWolf which did not use Snap.
    – gimmegimme
    Mar 14, 2023 at 22:10

I had the same problem. I noticed that when this happens, the Swap is full, while there is memory available. I increased the size of the Swap to the same size of the memory, using this instruction.

I also adjusted the value of the swappiness, from 60 to 40:

vm.swappiness = 40 #Follow the instructions provided above

I also changed the cache pressure settings, from 100 to 80:

vm.vfs_cache_pressure = 80 #Follow the instructions

And my Ubuntu never froze again, even when running Firefox, Spotify, Steam, and Discord at the same time.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .