Operational system: Lubuntu 18.04 // upgraded forcefully from 16.04
    architeture: amd64 
    Video graphic card: GeForce 7200 GS / 7300 SE

Everything was functioning normally, but sometimes when i was watching videos on the YOuTube [in G. Chromer] the screen froze with only the sound of the video continuing and even trying to turn on/off Num/Caps Lock keys didn't nothing, so i had to restart the computer when this happened. I figured that the problem may be the drivers, so i thought that i should reinstall the drivers. I purged the nvidia drivers, and tried reinstalling it, and it messed everything. Now my screen is widescreen and stretched and the image is bad. i tried reinstalling again the drivers [both by apt-get install and aptitude install] but nothing really happens after installing the drivers.

I can't open the Nvidia X Server Settings [it is in the menu, if i click on it nothing happens]. Some commands i used and their outputs:


 ERROR: Unable to load info from any available system


$ lsmod | grep nvidia
$: command not found


$ sudo lshw -c display
  *-display UNCLAIMED       
       description: VGA compatible controller
       product: G72 [GeForce 7200 GS / 7300 SE]
       vendor: NVIDIA Corporation
       physical id: 0
       bus info: pci@0000:02:00.0
       version: a1
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress vga_controller bus_master cap_list
       configuration: latency=0
       resources: memory:fa000000-faffffff memory:e0000000-efffffff memory:fb000000-fbffffff memory:c0000-dffff

What should I do? I looked for many solutions in this site, but none of them worked for me.

Any help would be appreciated.

EDIT: I tried Terrance's link steps, and what i'm getting:

$ nvidia-settings

ERROR: NVIDIA driver is not loaded

ERROR: Unable to load info from any available system

$ nvidia-smi

Command 'nvidia-smi' not found, but can be installed with:

sudo apt install nvidia-340      
sudo apt install nvidia-utils-390

I still can't open the NVidia Server X Settings, nor can't i change things like screen size. Oh, and the latest driver that supports my graphic card is the 304, so i think that installing these drivers that doesn't support my graphic card may mess everything up more. The command "lsmod | grep nvidia" returns no output.

edit²: tried

$ sudo apt install nvidia-304
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following additional packages will be installed:
  lib32gcc1 libc6-i386
Recommended packages:
  libcuda1-304 nvidia-opencl-icd-304
The following packages will be REMOVED:
  libgl1-mesa-glx libglx-mesa0
The following NEW packages will be installed:
  lib32gcc1 libc6-i386 nvidia-304
0 upgraded, 3 newly installed, 2 to remove and 0 not upgraded.
Need to get 0 B/38,5 MB of archives.
After this operation, 188 MB of additional disk space will be used.
Do you want to continue? [Y/n] Y
(Reading database ... 171909 files and directories currently installed.)
Removing libgl1-mesa-glx:amd64 (18.0.0~rc5-1ubuntu1) ...
Removing libglx-mesa0:amd64 (18.0.0~rc5-1ubuntu1) ...
Selecting previously unselected package libc6-i386.
(Reading database ... 171896 files and directories currently installed.)
Preparing to unpack .../libc6-i386_2.27-3ubuntu1_amd64.deb ...
Unpacking libc6-i386 (2.27-3ubuntu1) ...
Selecting previously unselected package lib32gcc1.
Preparing to unpack .../lib32gcc1_1%3a8-20180414-1ubuntu2_amd64.deb ...
Unpacking lib32gcc1 (1:8-20180414-1ubuntu2) ...
Selecting previously unselected package nvidia-304.
Preparing to unpack .../nvidia-304_304.137-0ubuntu2_amd64.deb ...
Unpacking nvidia-304 (304.137-0ubuntu2) ...
Setting up libc6-i386 (2.27-3ubuntu1) ...
Processing triggers for libc-bin (2.27-3ubuntu1) ...
Processing triggers for man-db (2.8.3-2) ...
Setting up lib32gcc1 (1:8-20180414-1ubuntu2) ...
Setting up nvidia-304 (304.137-0ubuntu2) ...
update-alternatives: using /usr/lib/nvidia-304/ld.so.conf to provide /etc/ld.so.conf.d/x86_64-linux-gnu_GL.conf (x86_64-linux-gnu_gl_conf) in auto mode
update-alternatives: using /usr/lib/nvidia-304/alt_ld.so.conf to provide /etc/ld.so.conf.d/i386-linux-gnu_GL.conf (i386-linux-gnu_gl_conf) in auto mode
update-alternatives: using /usr/share/nvidia-304/glamor.conf to provide /usr/share/X11/xorg.conf.d/glamoregl.conf (glamor_conf) in auto mode
dpkg: error: version '-' has bad syntax: revision number is empty
dpkg: error: version '-' has bad syntax: revision number is empty
update-initramfs: deferring update (trigger activated)
INFO:Enable nvidia-304
DEBUG:Parsing /usr/share/ubuntu-drivers-common/quirks/dell_latitude
DEBUG:Parsing /usr/share/ubuntu-drivers-common/quirks/put_your_quirks_here
DEBUG:Parsing /usr/share/ubuntu-drivers-common/quirks/lenovo_thinkpad
Loading new nvidia-304-304.137 DKMS files...
Building for 4.15.0-20-generic
Building for architecture x86_64
Building initial module for 4.15.0-20-generic
ERROR: Cannot create report: [Errno 17] File exists: '/var/crash/nvidia-304.0.crash'
Error! Bad return status for module build on kernel: 4.15.0-20-generic (x86_64)
Consult /var/lib/dkms/nvidia-304/304.137/build/make.log for more information.
Processing triggers for libc-bin (2.27-3ubuntu1) ...
Processing triggers for initramfs-tools (0.130ubuntu3) ...
update-initramfs: Generating /boot/initrd.img-4.15.0-20-generic
/sbin/ldconfig.real: Warning: ignoring configuration file that cannot be opened: /etc/ld.so.conf.d/i386-linux-gnu_GL.conf: No such file or directory
/sbin/ldconfig.real: Warning: ignoring configuration file that cannot be opened: /etc/ld.so.conf.d/x86_64-linux-gnu_GL.conf: No such file or directory

$ nvidia-smi
NVIDIA-SMI has failed because it couldn't communicate with NVIDIA driver. Make sure that latest NVIDIA driver is installed and running.
  • What exactly have you tried? It can make it harder for us to help you when you leave such a broad range of solutions that might have helped. Have you tried askubuntu.com/a/1030901/231142 ? The NVIDIA driver installation is in the bottom half of the answer. If you want the CUDA toolkit as well, that is in the top half.
    – Terrance
    May 8, 2018 at 2:16
  • Tried things like reinstalling X, installing other Nvidia drivers, purging them again, installing all needed dependencies from anything i tried... oh... i tried to follow the steps on the link you provided, but it didn't help at all. I still can't open the NVidia X Server Settings. I'm unable to do simple things like resizing my screen... i could do that before messing up eveything. May 8, 2018 at 2:55
  • Yep, I just looked it up and confirmed that it is the 304 driver. Unfortunately the nvidia-smi is not going to work with that driver as it is not available in that package. Did lsmod | grep nvidia find the driver installed? And are you still having an issue with launching nvidia-settings? I am sorry about the link above, I didn't think about older cards not working with the newer drivers.
    – Terrance
    May 8, 2018 at 3:54

5 Answers 5


sudo apt-get install --reinstall xserver-xorg-core libgl1-mesa-glx

  • 1
    I did that command, i installed everything, but... still... I can't open the Nvidia settings, and i can't do things like resizing my screen. May 8, 2018 at 2:54

nvidia-304 driver has been removed from 18.04 because it run out of support and Kernel 4.15 doesn't compile it. Here is a patch, but I haven't tested it https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-304/+bug/1737750

Nouveau is the option that ubuntu gives but i might have some problem, for example Kodi doesn't support nouveau. more info:




I fixed the problem with:

sudo apt install libwayland-egl1 
sudo dpkg -a --configure

Seems to be some kind of issue with the 2 files libwayland-egl1 and the one which installs libwayland-egl1-mesa. Have noticed that with the libwayland-egl1-mesa installed lots of problems items won't open etc. Perhaps this is an upgrade issue since I have only come across this in upgrade situations so far.


Try adding:


to kernel options. It worked for me, no more frozen black screens.
I am using the NVidia driver 304-137 with a 4.17.0 kernel.

$ sudo prime-select nvidia

logout and re login, nvidia-settings will can open the nvidia-gui

  • If you're like me and don't know what prime-select is, take a look at this question that asks how am I supposed to use nvidia-prime?. Also note that this does not appear to be available on Debian. Just Ubuntu.
    – Adam Katz
    Mar 6, 2020 at 19:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.