4

Whenever I change language layout, this notification appears and after 3 seconds disappear and I do not want to see this notification.

layout switcher pop-up

5
  • 1
    Are you sure you see that thing in Unity? If not, please edit your question to reflect the desktop environment you are using. May 7 '18 at 21:39
  • yes i am sure my desktop is unity May 7 '18 at 21:54
  • @LinuxAsaad What's the output of the following command in Terminal: echo $XDG_CURRENT_DESKTOP?
    – pomsky
    May 7 '18 at 21:57
  • sorry, i thought my desktop was unity i did not care that is gnome. after run the above command, output was gnome May 7 '18 at 22:09
  • it overlay - crazy thing. It blocks any shortcuts with Ctrl+Shift. For example it is not possible to press Ctrl+Shift+P in Sublime for control panel
    – mpz
    Jul 23 '18 at 3:43
2

My solution for 18.04 LTS. As a Thai people, we have a norm to use the ` key to switch between en/th. So I try it too, and found out that when I chose (pressed) ` key in the settings 'Switch to the next input source', the system automatically choose Shift + ` in 'Switch to the previous input source' for me. And with this settings, when I pressed only ` ..I got a pop-up too. But when I try hold-pressed Shift key and then pressed ` ..NOW it's has no pop-up!. This more safety than the default 'SuperSpace(press these in simultaneously)' that can sometime-freezed the desktop. (But if you have to or want to use ` or ~ (both are on the same key) you can still copy it from characters map.)

0
1
  1. Turn OFF default values: Settings => Keyboard Shortcuts => Typing enter image description here

  2. Install gnome-tweaks and turn on your new key layouts: enter image description here

0

That language indicating overlay is part of the GNOME shell, so probably not so easy to switch it off completely.

As a workaround you may set another alternative keyboard shortcut to switch between input languages, for example Alt+Shift which will not show the overlay. To do so, follow the Q&A: Ubuntu 17.10 can't change the input switching shortcut to alt+shift.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.