1

I followed https://www.raspberrypi.org/documentation/configuration/external-storage.md and mounted my external seagate driver like this:

PARTUUID=225d3878-01  /media/external ntfs    defaults,auto,umask=000,users,rw 0 0

I tried UUID=... but it wouldn't work, it always gave me boot errors, couldn't even access shell.

In this way I did, it boots, but when I go to /media and do ls -la:

drwxrwxrwx  1 root root 4096 May  7 18:52 external

external is marked green, like it were different from other things. I get Permission Denied when I try to write to it, even with sudo, but the permissions are 777.

How to change these permissions to ones less permissive and make it writable by my user?

2

I also use a Pi and I also attach a extern HDD.

To get it working with ntfs you need 2 other tools:

sudo apt install ntfs-3g fuse

and then you can mount your drive with
-t ntfs-3g #is needed to get read write access to ntfs drives
-o #are some options
-uid=1000 #is the id of my main user you can also use names
-gid=100 #group id of users to make it simple -then we need a source my usb-stick with ntfs is located at SDC and the parition is SDC1
-the last point is the destination and I want it into /mnt/usbstick

sudo mount -t ntfs-3g -o uid=1000,gid=100 /dev/sdc1 /mnt/usb-stick

So the answer to your Qestion is NTFS-3G instead of NTFS.

If this is working you can also use it in your fstab.

Hint: NTFS-3G will always set access level to 777 so no wory if the folder is green :-)

br chris

br chris

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.