1
nitesh@nitesh:~$ sudo apt-get upgrade 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: The package libpython3.6-stdlib needs to be reinstalled, but I can't find an archive for it.
nitesh@nitesh:~$ sudo apt-get install python3.6
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: The package libpython3.6-stdlib needs to be reinstalled, but I can't find an archive for it.
**nitesh@nitesh:~$** sudo apt-get install --reinstall libpython3.6-stdlib
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: The package libpython3.6-stdlib needs to be reinstalled, but I can't find an archive for it.

I DOWNLOADED THE libpython3.6-stdlib package

nitesh@nitesh:~/Downloads$ sudo dpkg -i /libpython3.6-stdlib_3.6.5-3_amd64.deb
[sudo] password for nitesh: 
dpkg: error processing archive /libpython3.6-stdlib_3.6.5-3_amd64.deb (--install):
 cannot access archive: No such file or directory
Errors were encountered while processing:
 /libpython3.6-stdlib_3.6.5-3_amd64.deb
nitesh@nitesh:~/Downloads$ sudo dpkg -i libpython3.6-stdlib_3.6.5-3_amd64.deb
(Reading database ... 386961 files and directories currently installed.)
Preparing to unpack libpython3.6-stdlib_3.6.5-3_amd64.deb ...
Unpacking libpython3.6-stdlib:amd64 (3.6.5-3) over (3.6.5-5~16.04.york0) ...
dpkg: dependency problems prevent configuration of libpython3.6-stdlib:amd64:
 libpython3.6-stdlib:amd64 depends on libpython3.6-minimal (= 3.6.5-3); however:
  Version of libpython3.6-minimal:amd64 on system is 3.6.5-5~16.04.york0.
 libpython3.6-stdlib:amd64 depends on libreadline7 (>= 7.0~beta); however:
  Package libreadline7 is not installed.

dpkg: error processing package libpython3.6-stdlib:amd64 (--install):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 libpython3.6-stdlib:amd64
nitesh@nitesh:~/Downloads$ 
0

You can find any official package available for Ubuntu on packages.ubuntu.com. For your specific package, the result can be found here:

https://packages.ubuntu.com/search?keywords=libpython3.6-stdlib&searchon=names&suite=all&section=all

As the search result shows, this package is available for artful, bionic and cosmic. You can choose according to the version of Ubuntu that you are using.

  • No. This is not working. I reinstalled ubuntu.! – Nitesh May 9 '18 at 6:46
  • @Nitesh Which version of Ubuntu do you use? – Ho1 May 13 '18 at 17:20
  • @Ho Problem was in Ubuntu 16.04 but now I switched to 18.04 – Nitesh May 14 '18 at 7:18

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.