62

I have always used Alt+Tab key combo to switch between programs. Since upgrade to 18.04 only Super+Tab works.

How do I make both Alt buttons work with Tab to switch applications?

2
  • this happen to me after upgrading from 18.10 to 19.04
    – Dimitar
    Apr 20, 2019 at 8:55
  • 1
    worth noting here that , for me and 19.04 at least, I discovered that alt tab switches windows, and super tab switches applications. an application can have multiple windows, like Firefox and it's download window. I find that super tab preferable in that there are less icons to switch between, and I often have those multiple windows in another monitor anyway
    – pierrely
    Jul 24, 2019 at 5:36

8 Answers 8

89

In the Settings > Devices > Keyboard menu, you will find a list of keyboard shortcuts. Under the Navigation section, you can find the relevant functions and their associated shortcuts, and change them as you see fit. You're looking for the one named Switch applications.

3
  • 5
    This does not work for me, neither alt tab nor the predefined super tab do anything
    – select
    Oct 29, 2018 at 10:53
  • after some googeling I found a solution people.gnome.org/~federico/blog/alt-tab.html
    – select
    Oct 29, 2018 at 11:00
  • 2
    check for Switch windows directly and double click it and Alt + Tab then clcik set. All done.
    – Abhijith S
    Mar 26, 2021 at 11:56
27

Run gnome-control-center aka the Settings application.

Remove the shortcut for Switch applications by clicking on it and deleting it with the backspace key, now press the Set button.

Now set Switch windows by clicking on it, then press Alt + Tab and click the Set button.

4
  • how is this different from the other answers? Nov 1, 2018 at 14:56
  • 6
    It's different because "Switch applications" is not the same as "Switch windows", setting "Switch applications" did not work with my setup.
    – select
    Nov 4, 2018 at 16:40
  • 2
    This is the simplest and best.
    – Eric Mill
    Jan 6, 2019 at 1:24
  • 1
    @select thanks for pointing that part out, switch windows was definitely what I was expecting and not switch applications. Why that was changed in 18.04 I'll never understand because alt+tab to me (and probably most people) will mean "go back to the previous window". Just like you wouldn't change ctrl+z to act like ctrl+backspace - its not that same at all!
    – hazrpg
    May 30, 2019 at 9:25
7

Turns out the configuration just needs to be updated in settings.

Open Settings > Devices > Keyboard and under Keyboard Shortcuts select Switch applications and update it with left Alt+Tab.

Both Alt+Tab combinations should now work.

3

It is also possible to use Alt + Esc

Somehow maintainers think that this is better. However I always enable Alt + Tab

2


If my understanding of the problem stated here is correct try the following solution. It is a three stage process

Stage-1:
(1) Open Settings > Devices > Keyboard and under Keyboard Shortcuts
(2) Remove the shortcut for Switch applications by clicking on it and deleting it with the Backspace Key, now press the Set button.
(3) Remove the shortcut for Switch windos directly by clicking on it and deleting it with the Backspace Key, now press the Set button.

Stage-2:
(1) Create a new shortcut for Switch applications by clicking on it and then press Alt + Esc and click the Set button.
(2) Create a new shortcut for Switch windos directly by clicking on it and then press Super + Tab and click the Set button.

What we have achieved so far is simply swapping the key combinations for the following actions
Switch applications and Switch windos directly
Now let us proceed to the next stage

Stage-3:
(1) Create a new shortcut for Switch windos by clicking on it and then press Alt + Tab and click the Set button.

Voila
You have restored the behavior of ALT + TAB Key to what is required in this post. If for any reason things are not working you can execute the steps in Stage-0 (mentioned below) and then redo steps in Stage-1 and Stage-2

Stage-0:
(1) **Open Settings > Devices > Keyboard**
(2) In the top of the screen you can see the Reset All... button and then click it
(3) It will ask for confirmation. Click Reset All
Caution: TL;DR
The steps in this stage will remove any key customization you might have done in the past before you following the steps in this thread

That's all folks
Have a great time playing with keyboard shortcuts

1
  • Welcome to ask Ubuntu! Thanks for your contribution, however, I am not too sure how your answer really differs from any of the others, other than being more in depth. If you want to expand on an answer, it is better to just edit an existing answer with the extra info :) Jul 24, 2019 at 19:43
1

To get the same settings in 18.04 where alt+tab switched apps and alt+` switched windows within the same app:

Under Settings - Keyboard Shortcuts

In the Navigation section

  • Click Switch applications and hit alt+tab
  • Click Switch windows of an app directly and hit alt+`
0

Xubuntu 18.04 Lost Alt-F4 Log Out/Restart/Shut Down? This applies to Xubuntu (xfce) only. It may apply to more than 18.04. In a terminal execute xfce4-session-settings command to open the 'Session and Startup' panel. In the general tab, Logout Settings make sure that 'Prompt on logout' is TICKED. If this is not ticked then the command xfce4-session-logout will execute immediately. If it is ticked then a pop-up window will appear offering options Log Out Restart Shut Down or Cancel. If Alt-F4 does nothing, then create a keyboard short-cut for it: Open the mouse menu, select Setting, Keyboard and then the Applications Short Cuts tab. Click +Add at the bottom right. In the Shortcut Command tab, in the Command box enter xfce4-session-logout and click OK. Then hold down the Alt key and tap the F4 key. Close the panels. Now type Alt-F4 and the Log Out/Restart/Shut Down option panel should appear.

0

My problem was that in Window Behavior policy has been set to Focus under mouse.

I switched it to Focus follows mouse and Alt+Tab works alright now.

More on it can be read here: https://forum.kde.org/viewtopic.php?f=111&t=88727

enter image description here

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .