6

I have a problem with installing Ubuntu 18.04 LTS on my DELL XPS 15 9560 (though I haven't tried installing it on different hardware and thus am not sure if the bug is hardware or version specific).

After finishing all the steps in the installer the window just closes after a short pause, displaying the "waiting" cursor. Few moments after I get a crash report from plugininstall.py:

1 2 3

Shortly after that, ubiquity itself crashes. Can anybody suggest a workaround for this error?

1 2 3 4 5

  • Try to update all your packages, then if the problem persists, follow the bug report wizard. – pim May 7 '18 at 14:33
  • Does the uniquity installer crash after you've clicked Next, after you've entered your user information? In other words, it crashes on the "Copying files..." progress page, where the slide-show is supposed to appear? – PJ Singh May 7 '18 at 14:43
  • @pim I have just freshly downloaded the distro (packages shouls be up to date), following the wizard doesn't give anything as it just sends the report and closes everything – olex May 7 '18 at 15:33
  • @PJSingh exactly! Or, to be exact, I don't even get to see the slide-show (or anything else) after entering user details - the window just gets black for about 30s and then closes, followed by the usual "Ubuntu experienced a problem.." error message – olex May 7 '18 at 15:36
  • While it may be bug posted below, Dell has some other settings you may require. You do need to have newest UEFI from Dell. You need to change drive in UEFI from RAID to AHCI, but add AHCI drivers into Windows first if dual booting with Windows. dell.com/support/article/us/en/19/sln301754/… & Similar model askubuntu.com/questions/867488/… – oldfred May 7 '18 at 16:55
10

You are experiencing Bug #1751252.

There are two options to remedy this:

Option 1: Install a newer fixed version of ubiquity

  1. Boot your 18.04 Live ISO
  2. Select Try Ubuntu
  3. Before you start the Ubiquity installer, open a Terminal window (CTRL-ALT-T)
  4. Execute the following command in the Terminal to see which version of ubiquity you have

    dpkg -l ubiquity
    
    ||/ Name           Version      Architecture Description
    +++-==============-============-============-=================================
    ii  ubiquity       18.04.14     amd64        Ubuntu live CD installer
    
  5. If the version is 18.04.14, execute the following to update ubiquity

    sudo apt update
    sudo apt install ubiquity
    
  6. Verify that ubiquity has been upgraded to version 18.04.14.1 (note the .1 at the end)

    dpkg -l ubiquity
    
    ||/ Name           Version      Architecture Description
    +++-==============-============-============-=================================
    ii  ubiquity       18.04.14.1   amd64        Ubuntu live CD installer
    
  7. Start the installer by clicking on the Ubiquity icon, and it should now allow you to proceed through the installation

Option 2: Apply a patch to ubiquity

  1. Boot your 18.04 Live ISO
  2. Select Try Ubuntu
  3. Before you start the Ubiquity installer, open a Terminal window (CTRL-ALT-T)
  4. Execute the following commands in the Terminal to download and apply the patch

    cd ~/Downloads
    
    wget https://code.launchpad.net/~azzar1/ubiquity/+git/ubiquity/+merge/345056/+preview-diff/831305/+files/preview.diff --output-document ubiquity.patch
    
    sudo cp /usr/lib/ubiquity/ubiquity/misc.py /usr/lib/ubiquity/ubiquity/misc.py.original
    
    sudo patch /usr/lib/ubiquity/ubiquity/misc.py ubiquity.patch
    
  5. Start the installer by clicking on the Ubiquity icon, and it should now allow you to proceed through the installation

  • Thanks so much for that! I have seen a couple of launchpad bugreports for 18.04 but somehow did not find this one yet – olex May 8 '18 at 1:52
  • You're welcome! if this worked for you, please remember to accept this answer by clicking the checkmark, so others with this problem on AskUbuntu know there is a working solution. – PJ Singh May 8 '18 at 2:44
  • 2
    It did even work to just set the display scaling to 100% instead of 200%, as described in the launchpad bugreport (seems to be a bug affecting QHD displays in particular). But after the installer finishes and offers to reboot - it doesn't. Just gets stuck displaying the background. Force reboot via powerbutton shows GRUB, but does not boot at all (just showing bright screen). How could I find out why it did not finish the installation properly? It may or may be not still the effect of the bug – olex May 8 '18 at 16:32
  • 3
    @Ashu, Bug #1751252 affects HiDPI screens. If your install finished, then I assume Ubiquity worked. The purple screen is a separate issue, due to GDM login screen using Wayland with NVIDIA graphics. Solutions similar to this may help: askubuntu.com/questions/38780/…. After you are able to login, you should set GDM to not use Wayland: askubuntu.com/questions/967955/…. Also, search on AskUbuntu for other solutions to the new (2nd) problem you are facing. – PJ Singh May 12 '18 at 23:17
  • 1
    @Ashu, please note Bug #1751252 affects Ubiquity on HiDPI screens. You were probably having other issues, unrelated to Bug #1751252. Also, the change above would not directly "mess up your system"; it merely fixes the Ubiquity installer in your Live environment in order to patch Bug #1751252. If ubiquity fails, for any reason, you may end up with a failed install. For those affected by this bug, Canonical published a fix in the updates repository on 5/17/2018, so getting the latest version of ubiquity from updates the repository will resolve this particular bug for those affected by it. – PJ Singh May 19 '18 at 21:42
1

I had very similar problems installing 18.04 on an XPS-8900 desktop with a GT1030 graphics card and a 4K display. I found that two log files, /var/log/syslog and /var/log/kern.log, were expanding at a rate of about 1GB per minute until the disk filled and the system crashed. The messages in those files all referenced PCIE errors, and the kernel (boot) option pcie_aspm=off solved it, at least until updates can fix it.

With the USB Live Installer, the option can be entered from the GRUB menu with 'e'.

After the system is installed the option can be made persistent with

$ sudo nano /etc/default/grub

then after adding the option after quiet splash type

$ sudo update-grub

0

enter image description hereIf the error message reads like

The 'grub-refi-amd64-signed' package failed to install into /target/. Without the GRUB boot loader, the installed system will not boot

you should be able to fix the issue as follows. While creating partitions, create a partition for /boot/efi (select /boot and manually type '/efi') of 100 to 200 MB. Select as file system FAT32.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.