I just installed Ubuntu for the first time, downloaded 11.04 and updated to 11.10.
I have a setup with a NVidia 7600GT Graphics Card, with DVI-Out and VGA-Out. I have two displays connected to those plugs, and they work perfectly on windows. I updated to NVidia's latest driver with:

sudo add-apt-repository ppa:ubuntu-x-swat/x-updates  
sudo apt-get update   
sudo apt-get install nvidia-current

and i still can't get Ubuntu to recognize i have two displays...

Can someone help me please?

  • 1
    Does system preferences -> screen -> detect monitors help? If not try to create xorg.conf file and add manually second monitor. Do You know how to do it? – Misery Feb 11 '12 at 16:14
  • system preferences -> screen -> detect monitors -- that's what i am doing without success. i don't know how to create that file and add the second monitor... – André Alçada Padez Feb 11 '12 at 16:15
  • Tried sudo nvidia-settings yet? Might have to install nvidia-settings though. – user8290 Feb 12 '12 at 2:36

To configure your two monitors manually,

stop your display manager:

sudo stop gdm

if the process is not found, try ps -ax | grep dm to look for your manager.



and log in. After that create xorg.conf file:

sudo Xorg -configure

The contents of the file should be written on the screen and the path to the created file should be written also (path depends on how You are logged, as super user or as Your user and just using sudo command)

Edit created xorg.conf.new (it is created instead of xorg.conf, but it is the same):

sudo gedit xorg.conf.new

You should find sections responsible for screen card and monitor. In my case these are:

Section "Monitor"
    #DisplaySize      380   300
    Identifier   "Monitor0"
    VendorName   "AOC"
    ModelName    "919"
    HorizSync    30.0 - 80.0
    VertRefresh  55.0 - 75.0
    Option      "DPMS"

Section "Device"
    Identifier  "Card0"
    Driver      "radeon"
    VendorName  "ATI Technologies Inc"
    BoardName   "Radeon 2100"
    BusID       "PCI:1:5:0"

Section "Screen"
    Identifier "Screen0"
    Device     "Card0"
    Monitor    "Monitor0"
    SubSection "Display"
        Viewport   0 0
        Depth     1
    SubSection "Display"
        Viewport   0 0
        Depth     4
    SubSection "Display"
        Viewport   0 0
        Depth     8
    SubSection "Display"
        Viewport   0 0
        Depth     15
    SubSection "Display"
        Viewport   0 0
        Depth     16
    SubSection "Display"
        Viewport   0 0
        Depth     24

Copy Your monitor and screen sections and paste it somewhere in that file, and name (change Identifier) them Monitor1 and Screen1.

In Screen section corresponding to Screen1 change used monitor to Monitor1

Monitor "Monitor1"

reboot and then try to go to system->preferences->screen and detect monitors.

| improve this answer | |
  • when i run, sudo stop gdm i get unknown job... when i run Xort - configure i get Fatal server error: Server is already active for display 0 – André Alçada Padez Feb 12 '12 at 18:02
  • What desktop manager do You use? Gnome? – Misery Feb 12 '12 at 18:04
  • it's the default one when i install ubuntu 11.10, Unity i think – André Alçada Padez Feb 12 '12 at 18:05
  • so try: sudo service stop gdm and then the rest – Misery Feb 12 '12 at 18:57
  • You get sudo: stop: command not found – Vincent Apr 29 '18 at 10:59

Open nvidia-settings and configure it there.

The proprietary driver does not integrate very well with Ubuntu's system settings.

| improve this answer | |
  • 1
    thanks, when i run that and select XServer Display Configuration, i get Unable to load X Server Display Configuration page: Failed to query NoScanout for screen 0. And on the menu, i only see X Screen 0 – André Alçada Padez Feb 12 '12 at 18:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.