1

Sometimes my system doesn't go shutdown when I click at this element of menu. If I run "sudo halt", system freezes at the splash screen. Why? What can I do to solve this problem?

Thank you. Sorry for wrong English.

  • Try using the System Monitor to view any processes that might be running and causing the issue. If you can see what's running at the time of shutdown, it may help pinpoint and start troubleshooting the cause. – Jeremy Jared Feb 11 '12 at 15:17
  • You might also look at the log file viewer for possible solutions. – Jeremy Jared Feb 11 '12 at 15:20
  • OK. At the next time when system won't go shutdown. UPD: But where are log files? – Ivan Akulov Feb 11 '12 at 15:39
  • You should have an application named log file viewer. If you open the log file viewer it usually automatically opens your error log. – Jeremy Jared Feb 11 '12 at 17:31
  • I do not have it :( – Ivan Akulov Feb 12 '12 at 11:51
0

This is actually a bug, and many of us are concerned. It occurs only in Unity and sometimes in Gnome-shell. (Kubuntu, Lubuntu, Xubuntu... are fine).

For the time being, you have to use your user password to logout/shutdown

I personally did this as I am the only one to use my computer:

  • Open Keyboard shortcut dialog (from System settings) and add a new keyboard shortcut with a custom command line:

Custom Keyboard Shortcut with Logout command line in Unity

In The above example, once you clikc ALT+CTRL+BACKSPACE, you should be prompted to type your user password graphically and logout properly.

Repeat the same procedure for shutdown :

gksudo shutdown -h 0
| improve this answer | |
  • Thanks a lot, bot now about for 2 weeks system shuts down normally :) But I'll remember this solution – Ivan Akulov Mar 4 '12 at 6:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.