13

Since 17.10 I got familiar with Wayland and I really need the per-monitor-scaling!

How can I start a wayland session after dist-upgrade to Bionic? There is no option in GDM available out-of-the-box.

I do not see what is described as

The Wayland session will still be available, pre-installed

Bionic Beaver 18.04 LTS to use Xorg by default

12
  • 3
    Don't you see a cogwheel (⚙️) next to the sign in button in GDM login screen?
    – pomsky
    May 7, 2018 at 7:32
  • yes, but there is no option for wayland available.
    – user200016
    May 22, 2018 at 18:31
  • 2
    The problem might be that you upgraded. In a fresh installation of Ubuntu 18.04 LTS, there is 'action' behind the cog wheel. (I have a fresh installation, and I can switch between Xorg and Wayland; I am running Wayland most of the time). -- Unfortunately the upgrade scripts are not quite mature yet. We can expect things to work smoothly when the first point release, Ubuntu 18.04.1 LTS, is uploaded, late July or early August.
    – sudodus
    Jun 5, 2018 at 10:16
  • 1
    @sudodus I have a fresh install, no cog though. Maybe it's because it's a "minimal desktop" install
    – Szabolcs
    Sep 24, 2018 at 11:49
  • @Szabolcs, what do you mean by minimal desktop install? Which version of Ubuntu? Which desktop environment? How did you create it? You can also describe your computer (brand name and model). I suggest that you create an own question, where you describe your case. You can link to it from a new comment here.
    – sudodus
    Sep 24, 2018 at 11:57

2 Answers 2

12

On the login screen, you should be able to select "Ubuntu on Wayland" by clicking on the settings icon, next to the login button.

If that option is not available under the cog icon on the password screen, make sure that WaylandEnable=false is commented out (or not present) in /etc/gdm3/custom.conf

Mine looks like this:

# GDM configuration storage
#
# See /usr/share/gdm/gdm.schemas for a list of available options.

[daemon]
# Uncoment the line below to force the login screen to use Xorg
#  WaylandEnable=false

# Enabling automatic login
#  AutomaticLoginEnable = true
#  AutomaticLogin = user1

# Enabling timed login
#  TimedLoginEnable = true
#  TimedLogin = user1
#  TimedLoginDelay = 10

[security]

[xdmcp]

[chooser]

[debug]
# Uncomment the line below to turn on debugging
# More verbose logs
# Additionally lets the X server dump core if it crashes
Enable=true

If you cannot log in to change this, start Ubuntu into recovery mode, go into root shell, and mount root partition as read/write: How do I boot into recovery mode?

From there edit the GDM config with nano /etc/gdm3/custom.conf and comment out the WaylandEnable line: #WaylandEnable=false

7
  • «not sure why» is a bit scary. anyway, a new installation is not an option for me.
    – user200016
    May 29, 2018 at 11:34
  • 1
    thank you for the addition. i am in the sudo group, so i am able to edit the file, but the named line looks good already.
    – user200016
    Jun 6, 2018 at 11:07
  • 6
    I'm not seeing that option, I just see "Ubuntu", and "Gnome Classic", neither of which use Wayland. WaylandEnable = false is commented out.
    – Hassan
    Aug 27, 2018 at 5:33
  • it appears that is you have an nvidia card, due to what seems to be a fundamentalist dev war, the session option isn't shown. reddit.com/r/linuxquestions/comments/8q1ko0/… however, if you comment out #WaylandEnable = false i believe it does use wayland (at least, playing a game in lutris was very smooth after that change. (not sure how to check if wayland is running) Jul 3, 2020 at 16:51
  • also, you can enable and simply restart gdm, so edit as above and then run sudo systemctl restart gdm3 there is no need to log out or restart. Jul 3, 2020 at 16:53
9

I got this to work, but it was by specifically setting this option:

WaylandEnable=true

In any case, as mentioned elsewhere, this does not work on all applications.

Google Chrome continues to have monster fonts.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.