3

I am receiving an error while starting up a newly created virtual machine in ubuntu 17.10 using Virtual machine Manager. It worked fine once but I shut it down and now can't get it to start, I get - Error starting domain: internal error: cannot load AppArmor profile 'libvirt-

2
  • Is your system fully updated? Have you run sudo apt-get update followed by sudo apt-get dist-upgrade? Did both complete without warnings or error messages? And please edit your question to include the full error. It seems incomplete.
    – DK Bose
    May 7, 2018 at 3:47
  • This could indicate a wrong apparmor profile being generated. You can check the UUID via virsh dominfo and then check for /etc/apparmor.d/libvirt/libvirt-<UUID>.files if that looks sane. May 7, 2018 at 14:07

3 Answers 3

1

I had to uninstall apparmor competely followed by a reinstall of apparmor to make it work.

1

In my case the ISO image was on an mounted storage, so the solution was:

sudo nano /etc/apparmor.d/local/usr.lib.libvirt.virt-aa-helper

added the entries for iso:

/media/DATA/Downloads/Distros/** r,
/{media,mnt,opt,srv}/** r

That's it. The error is gone.

Reference: LibvirtApparmor - Ubuntu Wiki

0

I got the exact same error message on Ubuntu Server 18.04.1 x64 when moving kvm virtual machines from an older 14.04.5 Ubuntu Server install. Reinstalling apparmor didn't do it for me.

It turned out that I was missing the package libvirt-daemon-system. After installing this package, the virtual machines booted with no errors.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.