I have this problem with k3b in 18.04 releases (Ubuntu, Kubuntu, KDE Neon...) In oldest releases I do not have this problem:

cdrecord has no permission to open the device
You may use K3bbsetup to solve this problem. 

I've searched online but I have not found any solution.

Can anybody help me?

  • Now I use Ubuntu 18.04, but I have the same error. I could record with k3b running it as superuser, (sudo k3b), but I do not like to run programs like root, because it can generate various problems. In my Linux Mint 18.3 or in my Debian 9 I do not have this problem. – louiesanchezdj May 9 at 16:51
up vote 21 down vote accepted

Try attempting the following commands:

sudo chmod 4711 /usr/bin/wodim; sudo chmod 4711 /usr/bin/cdrdao

This will set the UID bit on the necessary binaries. It is illustrated in Settings -> Configure k3b -> programs -> Permissions "tab".

  • thank you very much. After trying a lot of things, your help solved the problem at first. – louiesanchezdj May 11 at 18:12
  • Works fine with Ubuntu Mate 18.04, I can now erase disc-rw with k3b. Could you more explain the commands chmod and 4711 ? – NicolasSmith Sep 1 at 6:33
  • chmod controls the permissions of the file. The four numbers (in this case of an executable file) mean: 4: If a user executes the file, it will be run in in root's context instead of the current user's, since only root can access /dev files writing, which is needed for CD/DVD recording 7: the user who owns the file (in /usr/bin usually root) is allowed to execute, modify and read the file 1: the file's assigned group (in this case root as well) is only allowed to execute it 1: all other users are only allowed to execute See also en.wikipedia.org/wiki/Chmod#Numerical_permissions – Nico R Oct 24 at 14:23

sudo k3b

temporarily. It works for me.

  • Temporarily It works for me too... but now I can not open k3b, I get an error with configuration files, I can not open the program because it does not find, or have been modified the configuration files. – louiesanchezdj May 10 at 14:17

drae answered this question correctly. The only thing he left out was that his command has to be performed in a terminal window to make it permanent. I just loaded a fresh install of KDE Neon and had this issue with k3b. Performed the command that drae said in a terminal window and everything works just as it did before. Nice answer drae.

  • Good feedback Terry, but this isn't actually an answer (but you've posted it in the Answer section). You can provide comments on individual answers using the "add a comment" link under the appropriate Answer - – cleary Oct 29 at 0:25

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.