16

I upgraded from Ubuntu 17.10 to 18.04 and realized tap to click is not reliable anymore. Approximately 40% of taps simply does nothing. Did you notice similar issues? Is it possible to fix this? (I use lenovo l450).

Edit: I use xorg session.

2
  • is laptop-mode-tools installed? May 6 '18 at 20:11
  • laptop-mode-tools is not installed
    – user241281
    May 7 '18 at 6:40
11

What ended up working for me was to remove the synaptics driver:

sudo apt remove xserver-xorg-input-synaptics

followed by a reboot. After that the touchpad worked again. I have a Dell XPS 15 9650.

1
  • oh thanks! It also fixed touchpad disabling functionality!
    – ada
    Sep 20 '18 at 7:43
6

Installing Touchpad Indicator worked for me!

2
  • 1
    Works for me, perhaps this tool should be included in Ubuntu...?
    – jdpipe
    Aug 8 '18 at 2:58
  • It works like a charm. Tested on LG Gram 2-in-1 laptop with Ubuntu 18.04 unity desktop
    – makerj
    May 10 '19 at 9:05
1

Adjusting Mouse Settings

Sounds like you just need to do some custom configuring to your touchpad to increase the sensitivity FingerLow (minimum amount of pressure required to register a tap). This can be accomplished with synclient:

First check your settings:

$ synclient -l

Then you can adjust your FingerLow/FingerHigh (or other) settings:

$ synclient FingerLow=2

Once you figure out your correct settings you will need to put them in a startup script as the synclient options will be reset on reboot. You can see more options, get more info and learn how to make a configuration script with this Great Tutorial on Touchpad Options.

You can also use xinput to get info and tweak some settings per this Great Tutorial on Configuring HID Devices. Here is a quick summary:

First, find your device name and ID:

$ xinput --list

Look at the output to determine your device name or id number and list its available properties:

$ xinput --list-props ID

This will show you the available options you can set. Then you can set them like this:

$ xinput --set-prop ID 'prop name' VAL
3
  • this doesn't work for me. Tapping doesn't work at all since upgrading to ubuntu and fiddling with synclient doesn't seem to fix it
    – glS
    May 8 '18 at 7:59
  • is not this because they switched from synaptics to libinput? will synclient work with libinput?
    – user241281
    May 8 '18 at 11:26
  • 1
    synclient is not installed by default in 18.04, so this doesn't seem to be the preferred way of doing things any more...?
    – jdpipe
    Aug 8 '18 at 2:57
0

The configuration recommendations above are great, I have exactly the same problem and it is definitely a sensitivity problem. I have found that an almost imperceptible tap, literally almost barely even touching the pad, raises the success rate of a click to around 90%. After years of plopping my finger on the pad it is a bit of an adjustment so I will be fiddling with the settings.

...

oh man that was easy...it was definitely the default spread between FingerLow and FingerHigh which left too small a tap range the following seemed to be the sweet spot...

FingerLow=25 FingerHigh=80

which in my case ended up only being one command:

synclient FingerHigh=80

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.