22

On Ubuntu 16.04 LTS I have used simple keyboard shortcut to set property Always on Top (Nautilus window as example):

  1. Alt+Space,

    Alt+Space to show window menu

  2. t

  3. After next Alt+Space or right mouse click I see that window was set to Always on Top.

    window is set to Always on Top

In standard Ubuntu 18.04 LTS with GNOME Shell I can press Alt+Space:

window menu on Alt+Space

but it does not react to t.

Seems to be a real bug 1710421 since 17.10.


How to enable such menu accelerators/mnemonics in standard Ubuntu 18.04 LTS?

  • 2
    4 yr. old gnome-shell bug, not going to be fix, you're wasting your time. Use any other shell and it works fine.. – doug Aug 20 '18 at 21:24
  • I'm using window manager right now so I can't really test it. But the second answer in this post, the one using wmctrl, I think it's worth a try. Not a direct answer to your question but you can use your keyboard at least. – aasril Aug 24 '18 at 6:14
  • 3
    One of the few questions where the question has more upvotes than the answer! :D :D :D Good question! – Fabby Sep 10 '18 at 10:39
  • why would they remove something that users are so accustomed to? – asgs Oct 13 '18 at 16:20
  • 1
    @N0rbert I'm a fan of XFCE and I've always liked it and used it. It's only the Ubuntu 16 to 18 upgrade that changed this behavior. is XFCE also using Gnome shell under the hood? – asgs Oct 13 '18 at 16:26
11

On GNOME Shell it is impossible! Welcome to the new brave world with unpredictable limits and problems!

To get these shortcuts on Ubuntu 18.04 LTS and 19.04 in place you can switch to:

  • Unity - installable with sudo apt-get install ubuntu-unity-desktop:

    Ubuntu 18.04 LTS with Unity desktop

  • GNOME FlashBack - installable with sudo apt-get install gnome-panel:

    GNOME FlashBack on Ubuntu 18.04 LTS

  • MATE Desktop Environment (my favorite, as it avoids GNOMEs Hell) - installable with sudo apt-get install ubuntu-mate-desktop^:

    Ubuntu 18.04 LTS with MATE DE

  • XFCE (xubuntu-desktop^) does not have mnemonic for Always on Top, but usable and looks very nice:

    xUbuntu 18.04 LTS

  • Cinnamon (cinnamon-desktop-environment) have all necessary mnemonics:

    Cinnamon on Ubuntu 18.04 LTS

  • KDE (kubuntu-desktop^) have mnemonics, they may be accessed from Alt+F3 (so called Window Operations Menu) - for example to keep window above others you need to click Alt+F3, M (for More Actions), A (for Keep Above Others) and menu is rich:

    Kubuntu 18.04 LTS

  • Openbox (openbox), LXDE / LXQT / Lubuntu (lubuntu-desktop^, lxqt) have mnemonics, they are accessed with Alt+Space:

    OpenBox, LXDE/Lubuntu/LXQT on 18.04 LTS

  • Budgie (ubuntu-budgie-desktop^) have mnemonics, they are accessed with Alt+Space:

    Ubuntu Budgie

  • 2
    Per inputs from N0rber, I managed to remove Gnome shell and switched to Xubuntu. I get Xfce's simplicity along with the Keyboard Mnemonics. It's a win-win! Thank you very much! – asgs Oct 13 '18 at 19:31
  • 2
    You could add LXDE/Openbox :) – Justice for Monica Oct 17 '18 at 17:22
  • 1
    @DKBose added LXDE/Openbox, thanks for suggestion :) – N0rbert Oct 17 '18 at 18:39
6
+50

The KISS (Keep It Simply Stupid) answer to that is to do a simple:

Alt+space and then Enter

not as good as Alt+space and then i, but still better than:

  • lifting your hand from the keyboard,
  • looking for the mouse,
  • pointing,
  • clicking
  • moving your hand back to the keyboard...

¯\_(ツ)_/¯

  • As of today, I can open the window menu with Alt+Space and move up and down the menu with the arrow keys. But I cannot use Enter to actually select any of the menu options. – eksortso Sep 14 '18 at 16:19
  • One more thing. The flippant "¯_(ツ)_/¯" response is insulting. I recommend editing it out. – eksortso Sep 14 '18 at 16:20
  • 4
    It's a shrug @eksortso : it means "It's not a perfect solution, just a workaround" – Fabby Sep 14 '18 at 21:10
  • 1
    Whenever I've seen that thing, the context suggested it meant "I don't know and I don't care." A harsh sentiment for a Q&A site, though I now suppose that wasn't your intention. And when I read that along with KISS, which once meant "Keep It Simple, Stupid" as an ironic maxim to developers, I interpreted your comment as frustration with the user, and reacted with hostility. Although I did try to remain civil, I'm not sure if actually I went too far. – eksortso Sep 16 '18 at 3:11
  • 1
    Kiss shouldn't be thought of as an "ironic maxim to developers" it should be thought of as words to live by under most, to all circumstances. – tatsu Jun 17 at 13:31
6

Unfortunately, there is no hotkey support anymore for the Alt+Space window menu. However, you have keyboard shortcuts for the most common actions. These do not require you to see the menu and reduce the effort to one single keystroke.

  • Minimize: Super+h.
  • Maximize: Super+up.
  • Move: Alt+F7.
  • Resize: Alt+F8.
  • Close window: Alt+F4.

These key assignments can be changed in Settings - Keyboard.

Always on top: such keyboard combination is not defined by default, nor exposed through Settings - Keyboard. You still can define a key combination using dconf-editor, or a gsettings command. For example, to set Super+t for toggling the window on top, issue the command

gsettings set org.gnome.desktop.wm.keybindings always-on-top "['<Super>t']"

Undo with the command

gsettings reset org.gnome.desktop.wm.keybindings always-on-top
  • I temporarily resorted to assigning <kbd>ctrl</kbd>+<kbd>alt</kbd>+<kbd>up</kbd> – asgs Oct 13 '18 at 16:21
  • This one worked perfectly for me. I had to wrap with quotes for this to work."['<Super>t']" – shan Dec 3 at 16:24
  • @shan Indeed, quotes are needed. Thanks for remarking this: I will correct asap. – vanadium Dec 3 at 16:54
1

The GNOME Shell extension Menu Keyboard Shortcut by Edward Jiang fixes my most used maximize/minimze mnemonic.

  • I'm back on ubuntu/unity but if ever have to deal with gnome again will use this. – javadba Oct 19 at 3:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.