1

I just downloaded the compressed files from Codeblocks website but there are so many .deb files.

So which one should I install? Do I have to remove currently installed Codeblocks 16.01 before performing installation? If anyone describes the process in a bit detail, it'll be really helpful. I am a newbie.

0

Codeblocks_17.12_1 works nice on a clean install of Ubuntu 18.04 LTS and spent a day coding and not seen any of the IDE`s usual GUI problems previously experienced when using Codeblocks v16.01 on Ubuntu 17.10+ ;)

Extra Dependencies Required (+current codeblocks-contrib);-

sudo apt-get install libwxbase3.0 cccc cppcheck cscope hunspell valgrind python3-pygments wx3.0

Then Codeblocks_17.12_1 and plugins install without problems.

Thanks Codeblocks coders and contributors, I have been using this IDE for many years.

  • Preparing to unpack codeblocks_17.12-1_amd64.deb ... Unpacking codeblocks (17.12-1) over (16.01+dfsg-2.1) ... dpkg: error processing archive codeblocks_17.12-1_amd64.deb (--install): trying to overwrite '/usr/lib/codeblocks/plugins/libabbreviations.so', which is also in package codeblocks-contrib 16.01+dfsg-2.1 dpkg-deb: error: paste subprocess was killed by signal (Broken pipe) Errors were encountered while processing: codeblocks_17.12-1_amd64.deb I am getting this error message – Riadath Akib May 10 '18 at 8:23
  • Maybe remove the old codeblocks contrib version:- sudo apt remove codeblocks-contrib && sudo apt autoremove – David Ramsay May 10 '18 at 14:22

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.