11

It is working well in Ubuntu 16.04. After upgrading to 18.04 it refuses to start.

enter image description here

Anyone has any idea ?

  • Aman - I tried with sudo. It didn't work. – JothamB May 7 '18 at 16:04
  • 1
    This is wrong to use sudo here. This is bad to advise to use it when there is no need to. – solsTiCe May 15 '18 at 9:49
  • Go to Settings > Region & Language > set Formats to United States. – Benny Jun 2 '18 at 12:19
  • Same issue here. It will start syncing, but the GUI to edit preferences won't appear. The .deb from the Dropbox website is dated 2015 so I'm wondering if Dropbox is phasing out Linux? Doesn't seem to have been touched in a while. – brightball Jun 27 '18 at 3:44
3

I had the same problem (tried it also with a fresh installation, same thing). It turned out to be a locale issue (apparently, dropbox does not install well with some locales). You can check your locale by running

locale

and find out which locales are available for you by running

locale -a

I've managed to install dropbox properly after changing my locale to EN_GB.utf8 (was EN_IL beforehand) by running

sudo update-locale LANG=EN_GB.utf8
sudo update-locale LANGUAGE=EN_GB.utf8

I guess that you can change your locale back to what suits you best after the installation.

  • It worked !! TODA mate :) – JothamB May 15 '18 at 14:06
  • There is a problem still. When I close the terminal or restart the system the env variable return to en_IL and dropbox refuses to reopen. Is there a permanent solution ? – JothamB May 15 '18 at 14:51
2

I opened language support, it asked me to install additional languages. Installed, restarted and it worked :)

0

You can try the following:

  1. Rename current installation of DropBox in your home folder:

     dropbox stop
     mv ~/.dropbox-dist ~/.dropbox-dist_old
     mv ~/.dropbox ~/.dropbox_old
    
  2. Reinstall nautilus-dropbox package and reconfigure it:

    sudo apt-get purge nautilus-dropbox
    sudo apt-get install nautilus-dropbox
    sudo dpkg-reconfigure nautilus-dropbox
    
  3. Install DropBox daemon in the home folder:

    dropbox start -i
    
  • 1
    i tried this but it didn't work :( – JothamB May 7 '18 at 16:02
0

I was able to run dropbox into indicator panel on mate ubuntu 18.04 with this command /usr/bin/caja-dropbox export XDG_CURRENT_DESKTOP=Unity && caja-dropbox start -i It followed from guide on removal of double icon from skype

0

If you're using Mate desktop you should try to uninstall nautilus-dropbox and install caja-dropbox. It worked for me a moment ago.

0

I had exactly the same problem. It was indeed to do with the locale settings. But I couldn't change it using the terminal (I live in Germany and that was the only option available), so I changed the language preferences using settings from dashboard

then changed the language preference there language preferences from settings

after a restart dropbox installed immediately

0

Seems a problem related to Python. Change it from "python" to "python2" and config the autostart It worked perfectly to me

sudoedit /usr/bin/dropbox
--- #! /usr/bin/python
+++ #! /usr/bin/python2

dropbox autostart

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.