8

Not much to elaborate on my side: how can I enable japanese input on ubuntu mate 18.04? I tried adding japanese language support and restarting. But I still don't see any viable keyboard layout to add.

  • Take a look here. I think that section may provide some guidance, even if it refers to Ubuntu with Unity. – Gunnar Hjalmarsson May 6 '18 at 16:43
  • 1
    Indeed, I didn't notice initially I have to select the input method as fcitx. Now I can add "mozc" in the fcitx configuration. The thing is, it results in two language indicators and although I can switch to mozc by the keyboard shortcut, if I try to click on the second language indicator everything halts and becomes unresponsible forcing me to hard restart the PC... – Kalmar May 6 '18 at 20:11
  • 1
    AFAIK there is no integration between the Ubuntu MATE desktop and Fcitx (or IBus). So if you need an input method, such as fcitx-mozc, I think you'd better use Fctix for all the input sources you need, and ignore the original layout indicator. – Gunnar Hjalmarsson May 6 '18 at 20:17
  • I can't help but feel disappointed. I expected nowadays internationalization is not an issue for a respected OS Ubuntu strives to be. In fact Japanese input worked very well a few releases ago with IBus. – Kalmar May 8 '18 at 0:05
  • Please don't mix up Ubuntu with the flavors such as Ubuntu MATE. In standard Ubuntu, the IBus input methods are well integrated in the desktop and presented to the user together with the XKB keyboard layouts. The flavors don't have the same resources. At the same time, you can input Japanese also on MATE, right? – Gunnar Hjalmarsson May 8 '18 at 0:13
5

On Ubuntu 18.04, the way to install Japanese input:

  • Go to system settings, select "Region & Language".
  • Go to "Manage Installed Language" and install Japanese through "Install/Remove Languages". (you might need to log out and login after installation).
  • After installation, inside "Region & Language" dialog, click "+" to add input sources. select "Japanese" > "Japanese (Mozc)".

That's it. You can select Japanese input on one of the button on top right menu.

| improve this answer | |
  • I suggest apt install anthy ibus-anthy, reboot, then add input source "Japanese (Anthy)" (if you use ibus of course) – e2-e4 Oct 12 '19 at 9:59
  • If you install Japanese as the only language in Regional settings, then the interface will switch to Japanese after relogin. So important tip: install both Japanese AND the language of the interface you'd like to keep (e.g. English). I discovered that by trial and error... – ob-ivan Jan 14 at 11:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.