This question already has an answer here:

I have bought a new HP BS180TX laptop and installed Ubuntu 16.04 LTS and found that the wifi and bluetooth are not working. Wired connection works fine. I ran lspci -knn | grep Net -A3; rfkill list and the result I got is

03:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. Device [10ec:d723]
    DeviceName: WLAN
    Subsystem: Hewlett-Packard Company Device [103c:8319]
2: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no

What should I do?

The second answer here resolved my issue.
The first one did not work because the kernel version was not compatible. This even works in Ubuntu 18.04. I have tested this.

Bluetooth issue also fixed by the help of this thread

In 18.04, the kernel update can disable wifi. So you will have to redo the steps in the above answer I mentioned to re-enable it.

marked as duplicate by pomsky, karel, Eric Carvalho, Zanna, Pilot6 May 9 '18 at 23:46

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • @pomsky: Updated. – arshad May 6 '18 at 14:39
  • It didn't work either. Got an error executing the 5th command. – arshad May 8 '18 at 16:53
  • Try the other answer, first answer may not work with newer kernels. – pomsky May 8 '18 at 16:54
  • 1
    Oh, it worked. I didn't try it because it was not upvoted even once. But now I did. I wanna share that as an answer here. Is that ok? – arshad May 8 '18 at 17:48
  • 1
    I would recommend not duplicating an existing answer from Ask Ubuntu itself. Simply "accept" the duplicate by clicking on the button, no harm in that, it would mark your question as a "signpost" to the other question so that others get directed easily :) Also consider leaving a comment below the answer with your laptop model and kernel version (uname -r) saying that this answer worked for you while the other didn't. – pomsky May 8 '18 at 18:09