42

I ran into a problem this week, where I couldn't find a solution to.

Everytime I start Ubuntu, it boots nominally, until it reaches "starting Gnome Display Manager" where the Konsole gets stuck and the screen is going black every few seconds.

I also cannot access any tty by pressing Ctrl + Alt + F1, F2

I found an older question, where they solved the problem by reinstalling a new Nvidia Graphics driver.

I can't try that, because I can't access a shell, and my Ubuntu runs fully on Intel Graphics. (Lenovo Ultrabook)

Can I still use my Ubuntu, or do I have to wipe the partition?

1

5 Answers 5

36

I had the same problem after installating 18.10 on my Thinkpad T430s where Nvidia drivers were installed. Doing a

sudo apt-get remove --purge nvidia-*

inside the recovery mode root shell solved the problem for me.

1
  • 5
    Greet Its Work for me, I did Ctrl+Alt+F2 for get terminal & run this after login
    – matinict
    Nov 13, 2018 at 7:22
14

got same kind of gdm3 not responding (no greeter) after an upgrade to 18.04, from 17.10, on a i386 machine (namely, a very old MacBook) with Intel graphics.

I still could access it by SSH, but no longer by ctrl+alt+F1 or whatever, no more local access.

What should work considering what has been working for me is to disable GDM3 and to switch to whatever else doing the same thing, either Lightdm or Xdm

You can still access the recovery mode (hold shift key at boot) and get into a shell terminal I think. It was the case for me.

I did

sudo apt-get install xdm

and finally chose to switch to lightdm.

But actually

sudo dpkg-reconfigure lightdm

should display the same menu, providing Lightdm has been installed before, and you may be able to select it.

2
9

After upgrading my system to linux-image-4.15.0-24-generic, I experienced this issue where boot hangs at either started dispatcher daemon for systemd-networkd.ce or Started Gnome Display Manager.... This is how I solved it:

I booted up my laptop, went to recovery options and selected kernel linux-image-4.15.0-23-generic. Upon bootup, I did Ctrl+Alt+F2 (if the tty2 freezes, do Ctrl+Alt+F1 and back again to Ctrl+Alt+F2), dropped me to tty2, where I:

  1. Purged the kernel
  2. purged gdm3
  3. Reinstalled gdm3 & ubuntu-desktop

See below:

sudo apt purge linux-image-4.15.0-24-generic linux-headers-4.15.0-24\*
sudo apt-get purge gdm3
sudo apt-get install gdm3 ubuntu-desktop
reboot
2
  • I had a bit of difficulty with this, because I'm new to Linux / Ubuntu, but it worked for me. The problem for me was that I had to reboot after the 2nd step. Then all I had was a console -- no ubuntu desktop but I ran that 3rd step and it worked great. Thanks
    – raddevus
    Oct 17, 2019 at 2:29
  • Thank you, this solved my problem. Tried everything, purging and reinstalling worked!
    – dresden
    Mar 20, 2021 at 12:11
4

I got into the same state as you when trying to install the NVIDIA CUDA 9.x tool-kit on Ubuntu 18.04.

My issue was the CUDA install failed and left my nvidia drivers in a bad state, causing my system to hang at the Gnome Display Manager. See here for the solution.

If you are not able to access the tty at all, boot into recovery mode and use the root terminal.

Once you have access to a terminal, run:

sudo apt-get install -f

This will provide a report on any packages that failed to install.

If there are packages that are not properly installed use:

sudo apt-get remove --dry-run to remove them.

1

Seems to still be an Issue, even with the brand-new 19.10 dev.

To answer a part that wasn't looked at so much:

If you don't see a GRUB menu, it is probably hidden. One can try to Press C, SHIFT or ESC and hold it. The timing seems to be important, hit and stay as soon as you see "Grub Loading Message" or alike. Other users report that pressing the key repeatedly helped. (Source: different answers here)

This way, you can easily access the recovery mode or recovery console, which wasn't so easy for me.

The Q/A from above also contains answers how to permanently show the GRUB menu which is not the topic here.


On my system, it didn't have to do with the GDM as this was not installed on my system. If it is on your system, the common fix seems to be this alternative approach, where you need to uncomment this line of /etc/gdm/custom.conf

#WaylandEnable=false
1
  • i am having the same issue with ubuntu 20.04 "focal fossa" anyone please help
    – vatsalay
    Aug 20, 2020 at 8:27

Not the answer you're looking for? Browse other questions tagged or ask your own question.