79

So, when I suspend my laptop, then wake it up later, my laptop does turn on, I'm able to, for example, turn up and down the volume with audio confirmation using the kepboard, but my screen remains black and doesn't show anything until after I restart my laptop.

4

13 Answers 13

32

It is the buggy nouveau driver again. That's what solved the issue for me. Edit the file /etc/default/grub (using Vi editor -- some users have not been able to save after editing in Vi and have had to use the alternate "Ex" editing mode, which substitutes sudo edit below, then Alt+:w and :x for the save and exit commands).

$ sudoedit /etc/default/grub 

Add nouveau.modeset=0 to the line that says GRUB_CMDLINE_LINUX then press CtrlO to save the file and CtrlX to leave Editor.

Run

$ sudo update-grub

Now reboot.

9
  • 6
    It didn't work for me - using GTX 970 with nvidia-390 driver. – Soichi Hayashi Aug 10 '18 at 20:51
  • Seems to work for me. Using GTX1050 and nvidia driver, with Samsung 4K monitor 28 inch – Roland Aug 20 '18 at 9:57
  • 4
    I have a NVIDIA GTX1050 Ti on 18.04. For me this solution screwed my display resolution without the option to fix it after a reboot. Went to "Software and Updates" (it's in the application list), in "Additional Drivers" I found it was using "X.Org X Server Nouveau Display Driver" and not the NVIDIA provided driver. I selected NVIDIA driver and removed the nouveau.modeset=0 (suggested above) did update-grub and rebooted. Now suspend/resume seems to work well. Hope this helps someone. – Ravi Jul 25 '19 at 12:09
  • What about AMD users? This sounds awfully familiar... – AER Apr 19 '20 at 8:20
  • 1
    How will the edited file look?? I don't quite understand. – Sayed Sohan May 11 at 2:08
19

That seems graphics card driver problem.
Try Ctrl + Alt + F3 then Ctrl + Alt + F2 (might be F7) this might turn on display.
But it's temporary solution.

You may want to persistent solution then you can try to upgrade or change your graphics driver or try @cascagrossa's grub settings solution.

2
  • 2
    This solutions works for my setup. 2 monitors connected via DP to an nvidia 1080. When my power settings turn off my monitor 9/10 when resuming my secondary monitor receives the "No display signal" message and remains off. Using these key combinations has worked every time. thanks! – John Jan 6 '19 at 22:08
  • This used to work for me, but with some recent upgrade it has stopped working. On an MSI GP62/6QE. – talonx Feb 8 '20 at 15:22
5

for me switching from gdm3 to lightdm display manager did the trick

1
  • For this, I did apt remove gdm3 & it auto-switched to ligthdm (I think). Works like a charm, but I'd rather have gdm3 back if possible :( – shad0w_wa1k3r Apr 22 '19 at 14:50
2

i fixed it by changing Graphics BIOS configuration: Advanced -> Built-In Device Options -> Graphics, then switched from Hybrid Graphics to UMA Graphics. (on an HP laptop)

1
  • Thanks, worked for ZBook G5 Studio. Graphics setting seems to be problematic for HP's using Linux 18.04 or 19.04. I changed it from Hybrid to Discrete to make the Linux Installer work. Changing to UMA fixed this issue, but does disable the HDMI port. – javatestcase Aug 25 '19 at 15:24
2

Here is what fixed this issue for me on Kubuntu 20.04 Intel NUC PC (NUC8i7HVK), which has Intel HD graphics + embedded Radeon RX Vega M GH:

I went into UEFI BIOS settings and enabled PCIe ASPM (Active State Power Management). I left some other settings such as "Native ACPI OS PCIe" disabled

Enable ASPM in UEFI BIOS

This is very easy to test so give it a shot and see if it helps.

1
  • Saved me, thanks. I had a few options - Off / L0 / L1 / L0 and L1. I chose the last one and it fixed it. – homebrand Dec 14 '20 at 6:43
2

I don't know how to really solve the problem, but remember: before you hold down the power button to hard reboot, you can always soft reboot with this funky sequence:

Hold down Ctrl + Alt + PrScr, then press the following keys one-at-a-time while holding those first 3 keys down the whole time: R, E, I, S, U, B.

Note that on some (many?) laptops/keyboards,the PrScr button may require your Function key, Fn, to activate it, so you may have to hold down Ctrl + Alt + PrScr + Fn instead, while typing the REISUB reboot key sequence.

I don't remember where I learned this, but I read it from someone else years ago on Ask Ubuntu or SuperUser somewhere. The last key, "B", stands for 'B'oot. So, when you press that key your computer will restart.

Keep this in mind for any Linux problem. Only do a hard reboot if this soft reboot sequence first fails.


A few final thoughts:

  1. If you have a Yubikey plugged in, unplug it! It enumerates itself as a USB keyboard to your computer and may have a "jammed key" or otherwise interfere with your computer's normal operation. I make a USB keyboard device called the "Computa Pranksta" and sometimes have a similar problem.
  2. You may have a hardware problem, as I once had on my computer here. To test this, boot into your BIOS/UEFI boot menu and choose to run a full hardware diagnostics test suite, assuming your computer has such an option from the factory. It may reveal bad RAM, a bad motherboard, or something else.
  3. This answer by @Vijay Prema looks promising, but unfortunately I don't have the BIOS password on the computer I'm having problems on, so I can't change the BIOS settings to find out.
1

Sorry if what I'm saying is weird (I'm using the google translator). In my case, I am using an Asus Vivobook S15. After desperately searching, I accidentally gave the solution (in my case) and I wanted to share it. What I did was install the Unity Desktop:

$ sudo apt install ubuntu-unity-desktop

And although it seems absurd, it began to work, almost magically. I hope this information is useful for someone. A greeting!

0

I've found that simply pressing the function ("Fn") key wakes the screen up when all else fails. All else being other random key-resses.

0

I tried all the answers given in this post, none of them helped me(changed drivers, updated drivers, edited /etc/default/grub, changed display manager, made more swap, spent some hours, prayed to laptop).

I then finally gave up & thought to enable hibernate mode, while enabling that I ran

cat /sys/power/state

Which gave me

disabled

Then I felt it is due to UEFI boot mode in BIOS. Made that option to legacy support which enabled another option Boot priority, let this be default as UEFI First.

After this I am able to resume the system after suspend.

cat /sys/power/state

now gives more options which has suspend.

This was done on Legion Y540 (GTX 1650 with Nvidia drivers - 418 (no IGPU) /Ubuntu 20 LTS/ Kernel 5.4/ latest BIOS as of date)

P.S. Windows never had any problem resuming from sleep.

0

For KDE / Kubuntu:

Along with changing volume, I could also see the mouse cursor and was able to move it around in the black background(screen). Because of the black "screen", I was not able to login/logout or perform a graceful shutdown or restart.

Previously, killing plasmashell or Xorg from tty, would fix the issue, however this resulted in loss of open applications/windows and unsaved buffer data (like text in Kate etc.)

I finally figured out that I could kill kscreenlocker instead. To do the same.
  1. ctrl + alt + f2
  2. pkill -9 kscreenlocker_g or pkill -9 kscreenlocker_greet
  3. ctrl + alt + f1

Now, the kscreenlocker_greet should have restarted, allowing user login!

Note: This solution is restricted to KDE users only, however it doesn't require changing drivers/display settings, as suggested by above answers.

Cheers!

-1
  • Bring pointer[ arrow ] to the bottom of screen
  • Hold down left click bar which locate below touchpad of laptop then push arrow toward to center of screen which move the screen up and you will see the blank bar on the bottom of screen then click it .... It works for me every time....Good luck...
-1
  • Just try to change the boot mode to UEFI in bios.
  • I too encountered the same problem in my lenovo laptop.
  • Just changed the boot mode and i am running it flawlessly
2
  • 5
    Uh. "changed boot mode"? From what? To what? – zrajm Apr 8 '19 at 21:11
  • 2
    Wow: this is the epidemy of a bad answer... – Jaxian Nov 14 '19 at 12:20
-2

This seems to work for me (as a temporary solution).

Device: HP 245 G5

OS: Xubuntu 18.04

When your screen is blank, this sequence of actions seems to do the trick:

  • (wait 5 seconds)

  • CTRL + ALT + F2 (wait a second)

  • CTRL + ALT + F3 (wait a second)

  • CTRL + ALT + F7 (wait a second)

  • ESC (wait a second)

  • ENTER (3 times XD)

  • Close your laptop (wait 5 seconds).

  • Open back your laptop.

  • And the terrific blank screen is gone.

2
  • 10
    Then you do the hokey pokey and you turn yourself around... – Cosmo Apr 15 '20 at 13:22
  • I suspended my Ubuntu 18.04 laptop. Normally it wakes up, but about every 3 to 5 suspends it doesn't. This didn't work for me. :( – Gabriel Staples Oct 24 '20 at 5:41

Not the answer you're looking for? Browse other questions tagged or ask your own question.