31

I'm on Ubuntu 18.04 and since today whenever I lock my system and try to log back in using my password, it shows the 'in progress' spinner for few seconds then I get the error message "Authentication error". I can successfully log in on the first start though.

I have tried to force disable Wayland by uncommenting the line #WaylandEnable=false to WaylandEnable=false in /etc/gdm3/custom.conf but it had no effect. I was originally using Xorg as well.

I've checked for any available system updates in hope of getting a fix but none are available. What can I do to investigate into and fix this error?

Update: I re-installed Ubuntu 18.04 to get rid of the issue.

6
  • 1
    No responses! Is there really nothing that can be done? The upvotes indicate that others are facing this issue as well. Well, after spending about 3 hours trying to resolve this, I finally re-installed the operating system and spent the weekend setting up the laptop. May 7, 2018 at 0:07
  • What made you think Wayland was the problem? May 11, 2018 at 22:01
  • @WinEunuuchs2Unix some posts on the Internet. May 12, 2018 at 7:44
  • 2
    Next time please include a link to the reference you were following so that others can confirm it is relevant to the problem at hand. May 12, 2018 at 14:27
  • @WinEunuuchs2Unix got it. May 13, 2018 at 5:40

9 Answers 9

12

The gnome reconfigure command did not work for me.

What did work was changing fs.inotify.max_user_watches. I used this solution: https://askbot.fedoraproject.org/en/question/115963/gnome-authentication-error-when-logging-in-after-lock/

5
  • it seems like an update has been provided by Canonical having fs.inotify.max_user_watches=1048576 setting inside the /etc/sysctl.d/99-sysctl.conf file. unfortunately up to date the problem hasn't been solved with this update yet Jul 4, 2018 at 15:19
  • It works like a charm!
    – Haozhe Xie
    Sep 13, 2018 at 13:17
  • Glad you found this. It has been driving me crazy!
    – Dashdrum
    Oct 16, 2018 at 19:58
  • Can you inline the steps here? the page ask.fedoraproject.org/en/question/115963/… is not found. i installed 18.10 fresh today.
    – tgkprog
    May 11, 2019 at 10:52
  • from medium.com/@at15/… edit /etc/sysctl.conf to add/ edit the line: fs.inotify.max_user_watches=524288
    – tgkprog
    May 11, 2019 at 10:56
10

I had the same problem. After running the following I can re-login from the lock screen.

sudo dpkg-reconfigure gnome-shell
5
  • I ultimately re-installed Ubuntu 18.04 to get rid of the issue. May 12, 2018 at 7:45
  • I came across my solution because you re-installed. I was looking for other ways than a full re-install. I thought I might re-install Gnome only since Gnome handles the login screen now. And a comment on a post (some other Gnome weirdness from a while ago) about re-installing Gnome was a suggestion to use dpkg to reconfigure. So I tried that, and my lock screen issue went away. May 12, 2018 at 22:47
  • not worked for me Mar 8, 2019 at 12:36
  • 2
    works like a charm Mar 27, 2019 at 7:54
  • Worked for me!!!. My question is, why this happened? Before that, I just reinstalled the system python. (I don't believe, that it should be connected)
    – Michael D
    Dec 29, 2020 at 10:18
5

You can unlock the screen from terminal and command line, avoiding reboot. This is a temporary solution while you work on a permanent one.

Press Ctrl-Alt-3 to open a terminal, or use SSH to access from another computer. To unlock all sessions, type sudo loginctl unlock-sessions . Then press Ctrl-Alt-2, for example, to go back to your (now unlocked) session.

For more details, please see Unlock login screen using command line

This does not solve the underlying problem, but lets you quickly get back to your session to save your work and try configuration changes, without having to reboot.

3

I experienced the same issue and by heading into a new terminal (Ctrl+Alt+F3) I ran sudo service gdm restart which switched back to a graphical login. Logging in didn't work and the warning on the terminal said a warning about not being able to watch the file system, not enough disk space. The fix was increasing the max_user_watches as found in this article.

2
  • Yes it is worked for me... thank you for the solution. Mar 8, 2019 at 12:36
  • Fantastic. It got rid of a persistent (uncancelable) 'Authentication required to perform file operations' dialog at the top left of the screen for me. However, it does close all applications, so it is not unlike a logout/login without any questions to save work. Careful; you will loose work if you have not saved things. Jun 9, 2020 at 23:04
3

In order to resolve this issue open /etc/sysctl.conf file as root user in your favourite text edior. Now add fs.inotify.max_user_watches = 524288 at the bottom of the file and save it. Run sudo sysctl -p command in terminal to persist the changes you made in sysctl. And its done !

1

The gnome reconfigure command worked for me even after a completely clean reinstall failed. I had also tried to use the wayland log in and got stuck in a log in loop and had also tried to purge upstart which was apparently causing issues for some users.

1

Got this problem in Ubuntu 20, none of the solutions worked and I cannot even see the login screen after reboot....
Have to jump to the console by Ctrl+Alt+F1 to login through tty.

I solved this problem by reinstall gnome and ubuntu desktop in tty:

sudo apt-get install --reinstall ubuntu-desktop
sudo apt-get install --reinstall gnome-shell
1
  • The reason for this is that somehow gdm3 got uninstalled or deactivated. In my case the Ubuntu switched over to lightdm, but logging in was impossible.
    – JulianWgs
    Aug 1, 2021 at 13:44
0

I had similar issue. I ran the following to ensure all my packages were up to date

  1. sudo apt update & apt upgrade

The above displayed a message "6 packages to upgrade" I then ran the following to do an upgrade.

  1. sudo apt full-upgrade

Then reboot my desktop.

  1. sudo reboot

After reboot, the login screen should allow you to enter the password.

0

In my case, gnome wasn't proper. my error was dpkg: unrecoverable fatal error, aborting: unknown group 'geoclue' in statoverride file

So I had to go to statoverride and groupadd geoclue But still whatever files were there in statoverride file they were showing the same error, I had to groupadd all the groups, then sudo apt-get install --reinstall gnome-session ubuntu-desktop that's it. Took me almost whole day but it did work.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.