4

I'm on 18.04 in a Asus Zenbook laptop and my sound works fine after a shutdown (clean slate). If I boot into ubuntu, sound works, if i reboot still into ubuntu, sound still works. If I boot into Windows 10 and then shut down and boot into ubuntu, sound works. But if I boot into windows 10 and then reboot into ubuntu, now the sound doesn't work (nothing is muted in alsamixer but there is no sound at all). Only a shutdown fixes it, reboots don't. I already disabled fast boot in windows and killed/cleaned pulse audio as suggested in all these other answers. Sound doesn't work on headphones either

I took two syslog snapshots when sound works and when it doesn't and I don't see any significant differences between them. It really looks to me like a hardware/firmware issue but I imagine there must be a way to fix it from software. Any suggestions?

hilikus@developorium:~$ grep -C 3 snd no-sound-after-reboot  
May  5  developorium kernel: [    3.229033] cfg80211: Loaded X.509 cert 'sforshee: 00b28ddf47aef9cea7'
May  5  developorium kernel: [    3.232083] platform regulatory.0: Direct firmware load for regulatory.db failed with error -2
May  5  developorium kernel: [    3.232086] cfg80211: failed to load regulatory.db
May  5  developorium kernel: [    3.235334] snd_hda_intel 0000:00:1f.3: enabling device (0000 -> 0002)
May  5  developorium kernel: [    3.235547] uvcvideo: Found UVC 1.00 device USB2.0 HD UVC WebCam (13d3:5694)
May  5  developorium kernel: [    3.244124] uvcvideo 1-6:1.0: Entity type for entity Realtek Extended Controls Unit was not initialized!
May  5  developorium kernel: [    3.244126] uvcvideo 1-6:1.0: Entity type for entity Extension 4 was not initialized!
--
May  5  developorium kernel: [    3.416112] thermal thermal_zone6: failed to read out thermal zone (-61)
May  5  developorium kernel: [    3.417112] iwlwifi 0000:02:00.0 wlp2s0: renamed from wlan0
May  5  developorium kernel: [    3.804303] [drm] RC6 on
May  5  developorium kernel: [    3.832374] snd_hda_intel 0000:00:1f.3: bound 0000:00:02.0 (ops i915_audio_component_bind_ops [i915])
May  5  developorium kernel: [    3.861595] snd_hda_codec_realtek hdaudioC0D0: autoconfig for ALC294: line_outs=1 (0x17/0x0/0x0/0x0/0x0) type:speaker
May  5  developorium kernel: [    3.861597] snd_hda_codec_realtek hdaudioC0D0:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
May  5  developorium kernel: [    3.861598] snd_hda_codec_realtek hdaudioC0D0:    hp_outs=1 (0x21/0x0/0x0/0x0/0x0)
May  5  developorium kernel: [    3.861599] snd_hda_codec_realtek hdaudioC0D0:    mono: mono_out=0x0
May  5  developorium kernel: [    3.861600] snd_hda_codec_realtek hdaudioC0D0:    inputs:
May  5  developorium kernel: [    3.861601] snd_hda_codec_realtek hdaudioC0D0:      Mic=0x12
May  5  developorium kernel: [    3.915132] input: HDA Intel PCH Headphone as /devices/pci0000:00/0000:00:1f.3/sound/card0/input11
May  5  developorium kernel: [    3.915169] input: HDA Intel PCH HDMI/DP,pcm=3 as /devices/pci0000:00/0000:00:1f.3/sound/card0/input12
May  5  developorium kernel: [    3.915200] input: HDA Intel PCH HDMI/DP,pcm=7 as /devices/pci0000:00/0000:00:1f.3/sound/card0/input13

closed as off-topic by user68186, karel, pomsky, Charles Green, K7AAY Sep 27 '18 at 23:54

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Bug reports and problems specific to development version of Ubuntu should be reported on Launchpad so that developers can see, track and fix these issues." – user68186, karel, pomsky, Charles Green, K7AAY
If this question can be reworded to fit the rules in the help center, please edit the question.

  • The only time I had similar issues, I installed PulseAudio Volume Control, and that alone fixed it (of course when I opened the app and tweaked a little here and there). Do you have it installed? – M K May 5 '18 at 23:21
  • 1
    As per your own answer, it is a bug. Bug reports are off topic here. – user68186 Sep 24 '18 at 19:50
2

Windows is notorious for shutting off devices when rebooting and then powering them back on after rebooting. This is particularly problematic with Network cards but as your question illustrates it happens with sound cards as well.

From this Dell forum other users suffer the same fate. As stated you you can:

  • reboot into Windows 10
  • select shutdown
  • cold boot your system with power button
  • select Ubuntu

You can save time by suspending and resuming your Ubuntu 16.04 as one of the answer in this thread describes.

Summary

You can't reboot Windows and select Ubuntu from Grub menu. You have to shutdown and hit power button as per the links above. You could visit the Dell links and post a request for a Linux utility to power on the device.

The best solution may be to post a Windows question in Super User asking how to change Windows not to power off sound card during reboot.

  • thank you for the explanation. it will help me research more a solution knowing that the problem seems to be the windows audio driver. However, there are no solutions in your answer. Your solution of cold booting was already in my question, and I don't even need to boot into windows. any complete shutdown followed by linux boot fixes the issue, but not being able to reboot from win to linux with proper audio is the problem i'm trying to solve – Hilikus May 12 '18 at 1:02
  • also, which logs should i compare? as i mentioned, i compared already the syslog and they were the same between working and not working bootups – Hilikus May 12 '18 at 1:04
  • @Hilikus You can't reboot you have to cold boot as per the links in the answer. You could visit the Dell links and post a request for a utility to power on the device. The best solution may be to post a Windows question in Super User asking how to change Windows not to power off sound card during reboot. I've updated the answer with this comment. – WinEunuuchs2Unix May 12 '18 at 1:17
2

This ended up being a bug in the Realtek ALC294 alsa driver. It has been already reported in launchpad: https://bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/1742852

Upvote it if it affects you so that devs increase its priority

0

You can easily change that, telling your BIOS that you have another OS rather than Windows.
Open a command prompt and edit the file, with sudo nano /etc/default/grub
in the line that says GRUB_CMDLINE_LINUX_DEFAULT add the parameter acpi_osi=Linux
So it will be just like this GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=Linux, with that your Linux OS will take more control in your computer.
Suggested reading

  • I'm posting a solution but using windows, but wait a few hours... I'm downloading :P – Egon Stetmann. May 6 '18 at 0:17
  • maybe you hate as much as me, that the clock brokens every time you boot windows, read wiki.archlinux.org/index.php/time#UTC_in_Windows for fixing that – Egon Stetmann. May 6 '18 at 0:21
  • unfortunately, this didn't work. it made no difference – Hilikus May 12 '18 at 0:55
  • @Hilikus did you update the grub? – Egon Stetmann. May 12 '18 at 4:09
  • i didn't do i permanently in the file like you suggested. i did it by editing the grub entry directly in grub at bootup and then confirmed that the kernel argument was taken by running cat /proc/cmdline. So no need to update grub – Hilikus May 12 '18 at 16:02

Not the answer you're looking for? Browse other questions tagged or ask your own question.