0

I have just finished upgrading to 18.04 from 17.10 using

sudo do-release-upgrade 

then rebooted only to find that it cannot boot up again.

When I try to boot, it goes well until the systemd message:

Started Dispatcher daemon for systemd-networkd.files...tem changes.pp link was shut down...

where it starts flickering and stays there.

I tried older kernel versions, but the same thing happened. I also tried adding some boot parameters amdgpu.dc=0(from this answer) and nomodeset, but those only stopped the backlight from flickering with the display.

GPUs:

0:Intel HD Graphics 520

1:AMD Radeon R5 M330

UPDATE: I was able to disable gdm3 and make lightdm the default DM. Now it gets to LightDM, but it will never get to GNOME; it just loops (login loop). At least now I am sure the cause of the flickering is gdm3. Note: I tried gdm3 under both Wayland and X11, by editing /etc/gdm3/custom.conf, but the only difference was that with X11 I couldn't even see the systemd messages.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.