I installed ubuntu 18.04 after that my laptop getting hot near touchpad.I installed tlp but it didn't help.

  • Overheating is a hardware issue. However you can set CPU frequency to a lower value by using cpufreq github.com/konkor/cpufreq – kenn May 5 at 10:53
  • 1
    Then install cpufreq indicator sudo apt install indicator-cpufreq. You can set frequency via that systray indicator – kenn May 5 at 10:58
  • Can you check your system monitor to see if your CPU is constantly around 100%? – Calixte May 10 at 21:20
  • I just installed lubuntu 18.04 on an older laptop (2008, but 4 gb RAM). It overheats to the point of shutting off within about 10 minutes of logging on. Will try the suggestions here, but this computer has never overheated before unless I was running 3D games, so I haven't run 3D games on it for years. – user137 May 30 at 7:52
  • 1
    @user137 It's quite normal for laptops, I also set it to 800MHz, the temp is around 60 degrees. – kenn May 31 at 9:09

On my laptop, when booted 18.04, average CPU frequency is much higher in comparison to installed 14.04.

Current install is 14.04, fully updated, fan-less Acer laptop, 4GB ram, CPU Intel N2840 (up to 2.16GHz) based on cat /proc/cpuinfo. Avg CPU frequency around 600MHz based on cat /proc/cpuinfo most of the time when laptop is doing nothing.

Booted on this laptop 18.04 from USB, not installed. Laptop is doing nothing. CPU is running above 1GHz all the time, most of the time closer to 2GHz. Kept an eye on it for an hour, just looking at new interface, etc. CPU hovering between 1.2 and 2GHz.

Rebooted back to 14.04, CPU frequency is back to 500-700Mhz range.

Getting hot near touchpad means Hard Disk is overheating. It is more common in machines having 2GB or less RAM.

Step 1 (Decrease Swap Usage):

Open the Terminal and run:

sudo gedit /etc/sysctl.conf

Scroll to the bottom of the texts and paste the following two lines creating a newline at the end:

# Decrease swap usage to a more reasonable level
vm.swappiness=10

Save the file and reboot the machine.

Step 2 (Enable HDD Spindown):

Download and open Disks(gnome-disk-utility) app. Click the cogwheel icon on the top right and select "Drive Settings" Active Standby. Grab the slider of the “Standby Timeout Setting” and increase it to 20 minutes. Click OK button and give password to authorize the operation.

Go to the next(APM) tab. Active “Apply Advanced Power Management Settings”. Make sure APM level is not more than 127. Select OK and authorize the action using administrator password.

I had a similar problem. turns out it was actual high load that forced the cpu clock speed to always be more than 3GHz on all (!) cores. namely the xorg (>100%), systemd-journald (>50%) and rsyslogd(>30%) were consuming a lot cpu power. in the journal i could see the following line over and over again:

SynPS/2 Synaptics TouchPad: Read error 9

After a bit of digging I found that the synaptics driver should be replaced with the xserver-xorg-input-libinput. (which I had already installed, maybe that was the problem)

see: https://wiki.ubuntuusers.de/Touchpad/

So after removing the package xserver-xorg-input-synaptics the cpu load went down significantly and so did the cpu-clock and heat.

*

Open The Case

*

> 1. Blow The Dust
> 2. Try To Open Diagnostics ( For Dell Users )
> 3. Try To Spin It ( For All )

If It Didn't Work Try Fixing The Fan

  • I have the same problem, and it's definitely not hardware related. The CPUs are continually around 100% for no reason since the upgrade. There's no app using more than 1% of the CPU, but they're going nuts and the computer overheats in about a minute... – Calixte May 9 at 10:00

Maybe your laptop is having a problem with dust. Try clearing the fan and ventilation path. If its ok and still getting hot, then check if any application is consuming CPU higher. If its normal. then maybe your processor hit sink or fan is not working properly.

  • I have the same problem, and it's definitely not hardware related. The CPUs are continually around 100% for no reason since the upgrade. There's no app using more than 1% of the CPU, but they're going nuts and the computer overheats in about a minute... – Calixte May 9 at 10:00

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.