3

In previous Ubuntu versions there was a Nemo version without cinnamon dependencies but the PPA does not (yet?) include a version for Ubuntu 18.04 Bionic Beaver.
Is there another way to install the (latest version of) Nemo in Ubuntu 18.04 without cinnamon dependencies?

  • 1
    Well long story short I had ppa'd the webupd8 version for bionic during dev in anticipation of libgnome-desktop-3 upgrading but didn't notice nemo was going to also upgrade. So the ppa became useless for many unless they knew how to install downgrades (both ppa & repo were same version.) There was no simple way to rebuild in a ppa & I'm not inclined to fix the patches for the new libgnome-desktop-3 version. Note also that this was done specifically for a unity session so removed 2 patches & put in a more useful .desktop for unity' s launcher icon's actions though could also work ok in gnome. – doug May 27 '18 at 17:01
  • 1
    So to help out some users I recently came up with a way to rebuild to reversion higher. The ppa is here, if inclined to use i'd purge nemo if already installed & autoremove any other nemo packages (4 in total). Then install nemo & see.. launchpad.net/~mc3man/+archive/ubuntu/bionic-noprop – doug May 27 '18 at 17:03
  • 1
    Not at all. Just to note: the reason for the ppa was for 18.04 unity users who've tired of nautilus.. To that end I did remove the orig. ppa's dbus & .desktop patches & put in my own .desktop file patch so there were constant xdg folder quickists. Also note that if anyone who uses the ppa tries to get it's nemo build-dep they will fail as to get a new build required a sleigh of hand regarding libgnome-desktop-3-dev & the one used for the ppa is not in the ppa (for good reason, the libgnome-desktop-3 build in the ppa only has the shared lib.. – doug May 31 '18 at 22:12
  • 1
    While both libgnome-desktop-3-12 & 3-17 can co-exist in an install (or ppa) there can only be 1 libgnome-desktop-3-dev package (-dev packages are rarely 'versioned'). So any ppa (or local) build using that -dev package would use the current source version (3-17) in 18.04 which would fail without reworking the patches. To work around that I created a 'mirror' build of the 3-12 source in another ppa & versioned it so the build system would use that to build nemo. If users happened to install that -dev & gir1 packages it could cause issue so it's been hidden away so to speak. – doug Jun 1 '18 at 4:55
  • 1
    If you were to take a look at the package details in the ppa you'd see the libgnome-desktop-3 build there only has the -data and shared lib packages, no -dev & gir1 packages. – doug Jun 1 '18 at 5:00
5

Doug provided a PPA for this (see his comment).
He recommends to purge the installed nemo files before installing the new version. I did the following:

sudo apt purge cinnamon-desktop-data cinnamon-l10n gist hddtemp hwdata inxi libcinnamon-desktop4 libnemo-extension1 libxapp1 mesa-utils nemo nemo-data nemo-fileroller ruby-json xapps-common

Then added the PPA:

sudo add-apt-repository ppa:mc3man/bionic-noprop
sudo apt-get update

Then install nemo:

sudo apt-get install nemo nemo-fileroller

To make nemo the default file manager:

xdg-mime default nemo.desktop inode/directory application/x-gnome-saved-search

To handle the desktop just disable nautilus:

gsettings set org.gnome.desktop.background show-desktop-icons false

Reboot or log out

Thank you, Doug, for this great option.

  • 1
    As that was orig. just a ppa to insure I had working patched nemo for myself just decided today to change to "Label" (displayed name, not actual ppa name). If any issue with package manager or apt left simple instructions at bottom of description on main ppa page. Should only take a min. to do one time 'fix' launchpad.net/~mc3man/+archive/ubuntu/bionic-noprop Also added a mediainfo-tab plugin & fixed the media-columns plugin. – doug Jun 2 '18 at 22:02
  • Comment from user x7i7l: For some reason, on KDE Neon, Doug's repository doesn't help me. I've followed all the instructions but no matter what I do it still pulls in Cinnamon dependencies. I checked and Muon package manager is pulling in Doug's version. @doug Do you have an answer? – Filbuntu Nov 18 '18 at 13:13
  • run apt-show nemo check the deps & recommends, see if any of those are causing this in muon – doug Nov 18 '18 at 15:23
  • @x7i7l You probably figured it out, it is apt show nemo (not apt-show). – Filbuntu Nov 19 '18 at 0:15
  • @doug Is there a possibility to update Nemo in your PPA to a newer version? I think version 4.0.6 is already out. Cheers! – Filbuntu Jan 9 '19 at 4:43
1

I had the same problem, and the only (temporary) solution is to use the artful packages which should work (they're working for me) since Ubuntu 17.10 uses Gnome Shell anyway.

Just change /etc/apt/sources.list.d/webupd8team-ubuntu-nemo3-bionic.list to read deb http://ppa.launchpad.net/webupd8team/nemo3/ubuntu artful main You can also use the GUI by opening "Software & Updates" and editing the repo there, by changing bionic to artful.

Eventually, a Bionic repo will be available and then we can change the source again.

  • I don't experience any of those problems, it's as stable as it's always been. Make sure you don't have all configurations stored from previous Ubuntu versions – Felipe May 17 '18 at 22:55
  • Unfortunately Nemo crashes now & then (twice a day), especially when looking at the icons in a folder with mainly pictures. – Filbuntu May 19 '18 at 5:50
  • See my runaway comment below. – Moilleadóir May 25 '18 at 3:44
0

Moilleadóir you are right. Sudo apt install nemo would install the standard repo version (along with Cinnamon desktop).

To install nemo=3.6.5-1~webupd8~artful01 you need libgnome-desktop-3.so.12. In Bionic default is libgnome-desktop-3.so.17. Without this package (libgnome-desktop-3.so.12) nemo (3.6.5-1~webupd8~artful01) won’t start.

I found workaround (but you do it on your own risks):

First off all you need to add nemo artful packages (Felipe presnts how to do it)

Secend step: you need to manual install libgnome-desktop-3.so.12

You can found it here: https://packages.ubuntu.com/artful/amd64/libgnome-desktop-3-12/download

sudo dpkg -i libgnome-desktop-3-12_3.26.1-0ubuntu1_amd64.deb

Next step:

sudo apt-get install nemo-data=3.6.5-1~webupd8~artful0

sudo apt-get install nemo=3.6.5-1~webupd8~artful01 

sudo apt-get install nemo-fileroller=3.6.0-1~webupd8~artful 

To avoid actualization to sdandard repo version:

echo "nemo hold" | sudo dpkg --set-selections

echo "nemo-data hold" | sudo dpkg --set-selections

echo "nemo-fileroller hold" | sudo dpkg --set-selections
  • Thank you for this workaround! I really hope there will be an easier way or the PPA will be updated, though, as this workaround sounds a bit risky for me. – Filbuntu May 27 '18 at 7:01
-1

[This was a comment but it was too long!]

I have doubts about this working as it used to. The versions of Nemo in the webupd8team repo and the standard Universe repo are the same, but the Universe repo (version 3.6.5-1) is marked ‘bionic’ whereas the webupd8team one (version 3.6.5-1~webupd8~artful01) is marked ‘artful’. My guess is that sudo apt install nemo would install the standard repo version (along with Cinnamon desktop).

You could use Package | Force Version… in Synaptic to force the webupd8team version. I’m not sure if sudo apt install nemo=3.6.5-1~webupd8~artful01 would work or not as apt-cache policy nemo doesn’t list it as a candidate (i.e. it’s the wrong release).

If you run apt-cache policy nemo what version does it show is installed?


EDIT: I decided to gradually create a new 18.04 install in a VM, rather than upgrading 16.04 in August, so I’ve just got back to looking at this. The Nemo version in the standard repos does not install the Cinnamon desktop (unlike Caja which does look like it installs Mate). In my (limited) testing so far it seems to run fine.

  • You are right, it was the Universe repo version "3.6.5-1" that was installed with this solution and not the 3.6.5-1~webupd8~artful01 and the Cinnamon desktop was installed as well. – Filbuntu May 31 '18 at 13:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.