0

I have recently attempted to upgrade my system to Ubuntu 18.04 via:

do-release-upgrade

The installation froze while attempting to install libwine:i386 as several hours had passed and the installer would not advance. I finally decided to cancel the release upgrade and execute the following:

sudo dpkg --configure -a && sudo apt-get -f install && sudo apt-get upgrade

sudo dpkg --configure -a dpkg: dependency problems prevent configuration of wine32:i386: wine32:i386 depends on libwine (= 3.0-1ubuntu1); however: Package libwine:i386 is not installed.

dpkg: error processing package wine32:i386 (--configure): dependency problems - leaving unconfigured dpkg: dependency problems prevent configuration of widelands: widelands depends on widelands-data (= 1:19+repack-4build4); however: Version of widelands-data on system is 1:19+repack-4.

dpkg: error processing package widelands (--configure): dependency problems - leaving unconfigured Processing triggers for libc-bin (2.27-3ubuntu1) ... dpkg: error processing package libwine:amd64 (--configure): package libwine:amd64 cannot be configured because libwine:i386 is not ready (current status 'half-installed') dpkg: dependency problems prevent configuration of xorg: xorg depends on xserver-xorg (>= 1:7.7+19ubuntu7); however: Version of xserver-xorg on system is 1:7.7+19ubuntu3.

dpkg: error processing package xorg (--configure): dependency problems - leaving unconfigured dpkg: dependency problems prevent configuration of wine64: wine64 depends on libwine (= 3.0-1ubuntu1); however: Package libwine:amd64 is not configured yet.

dpkg: error processing package wine64 (--configure): dependency problems - leaving unconfigured dpkg: dependency problems prevent configuration of wine-stable: wine-stable depends on wine64 (>= 3.0-1ubuntu1) | wine32 (>= 3.0-1ubuntu1); however: Package wine64 is not configured yet. Package wine32:i386 is not configured yet. wine-stable depends on wine64 (<< 3.0-1ubuntu1.1~) | wine32 (<< 3.0-1ubuntu1.1~); however: Package wine64 is not configured yet. Package wine32:i386 is not configured yet.

dpkg: error processing package wine-stable (--configure): dependency problems - leaving unconfigured Errors were encountered while processing: wine32:i386 widelands libwine:amd64 xorg wine64 wine-stable

I then attempted:

sudo apt --fix-broken install

Reading package lists... Done Building dependency tree Reading state information... Done Correcting dependencies... Done The following packages were automatically installed and are no longer required: bbswitch-dkms caribou fonts-noto-color-emoji gcc-7-base:i386 gir1.2-caribou-1.0 gir1.2-clutter-1.0 gir1.2-cogl-1.0 gir1.2-coglpango-1.0
gir1.2-mutter-1 gir1.2-networkmanager-1.0 gir1.2-nmgtk-1.0
gnome-initial-setup gnome-todo gnome-todo-common gnome-tweak-tool
ibverbs-providers lib32gcc1 libapache2-mod-php7.2 libarmadillo7
libbabeltrace-ctf1 libbind9-140 libboost-atomic1.62.0 libboost-chrono1.62.0 libboost-chrono1.65-dev libboost-date-time-dev libboost-date-time1.62.0 libboost-date-time1.65-dev libboost-filesystem-dev libboost-filesystem1.65-dev libboost-iostreams1.62.0 libboost-program-options-dev libboost-program-options1.65-dev libboost-regex1.62.0 libboost-serialization1.62.0 libboost-serialization1.65-dev libboost-system-dev libboost-system1.65-dev libboost-test-dev libboost-test1.62.0 libboost-test1.65-dev libboost-test1.65.1 libboost1.65-dev libcamel-1.2-60 libcapnp-0.5.3 libcaribou-common libcaribou0 libcdio-cdda1 libcdio-paranoia1 libcdio13 libcodec2-0.6 libcppunit-1.14-0 libcppunit-dev libcuda1-384 libdfu1 libdns162 libedataserver-1.2-22 libedataserverui-1.2-1 libfabric1
libfcitx-gclient0 libfreerdp-client2-2 libfreerdp2-2 libfwupd1
libgcr-3-common libgeos-3.5.1 libgl2ps1 libgl2ps1.4 libgnome-desktop-3-12 libgnome-games-support-1-2 libgnome-todo libgnuradio-analog3.7.10 libgnuradio-atsc3.7.10 libgnuradio-channels3.7.10 libgnuradio-comedi3.7.10
libgnuradio-digital3.7.10 libgnuradio-dtv3.7.10 libgnuradio-fec3.7.10 libgnuradio-fft3.7.10 libgnuradio-filter3.7.10 libgnuradio-noaa3.7.10 libgnuradio-pager3.7.10 libgnuradio-qtgui3.7.10 libgnuradio-trellis3.7.10 libgnuradio-uhd3.7.10 libgnuradio-video-sdl3.7.10 libgnuradio-vocoder3.7.10
libgnuradio-wavelet3.7.10 libgnuradio-wxgui3.7.10 libgnuradio-zeromq3.7.10 libgom-1.0-common libgweather-3-6 libhamlib2 libhdf5-openmpi-100 libhwloc-plugins libhwloc5 libibverbs1 libical2 libicu57:i386 libidn11:i386 libisc160 libisccc140 libisccfg140 libisl15 libiso9660-10 libiso9660-8
liblept5 liblimesuite17.12-1 liblivemedia58 libllvm5.0:i386 liblog4cpp5-dev liblouisutdml8 liblttng-ust-ctl2 liblwres141 libmpfr4 libmutter-1-0 libnetcdf-c++4 libnetcdf11 libnm-glib-vpn1 libntfs-3g872 libopencv-core3.1 libopencv-flann3.1 libopencv-imgproc3.1 libopencv-ml3.1 libopencv-photo3.1
libopencv-shape3.1 libopencv-video3.1 libopencv-viz3.1 libopenmpi2
liborcus-0.12-0 libp11-kit-gnome-keyring libpoppler68 libprocess-cpp3 libpsm-infinipath1 libqcustomplot1.3 libqwt5-qt4 librdmacm1 librtaudio6 libsodium18 libsox2 libsrtp0 libssl1.0.0:i386 libsuitesparseconfig4 libsysmetrics1 libtbb2 libtesseract-data libtesseract3 libu2f-udev libunistring0 libunity-api0 libva-drm1 libva-wayland1 libva-x11-1 libvcdinfo0 libvlccore8 libvpx4 libvtk6.3 libwinpr2-2 libx264-148 libx265-130 libzmqpp4 nvidia-headless-390 nvidia-opencl-icd-384 openmpi-bin openmpi-common python-qwt5-qt4 ruby2.3 snapd-login-service tcpd unixodbc vlc-l10n vlc-plugin-notify vlc-plugin-samba vlc-plugin-video-splitter Use 'sudo apt autoremove' to remove them. The following additional packages will be installed:
libcapi20-3:i386 libwine:i386 widelands-data xserver-xorg Suggested packages: ttf-mscorefonts-installer:i386 The following NEW packages will be installed: libcapi20-3:i386 The following packages will be upgraded: libwine:i386 widelands-data xserver-xorg 3 upgraded, 1 newly installed, 0 to remove and 241 not upgraded. 7 not fully installed or removed. Need to get 0 B/183 MB of archives. After this operation, 9.108 kB of additional disk space will be used. Do you want to continue? [Y/n] y (Reading database ... 380233 files and directories currently installed.) Preparing to unpack .../libwine_3.0-1ubuntu1_i386.deb ... Unpacking libwine:i386 (3.0-1ubuntu1) over (2.0.2-2ubuntu1) ...

Lastly I attempted to manually download libwine:i386.deb and install it via dpkg -i however the installer just freezes.

Does anyone know how I might be able to fix this?

Many thanks

  • First you converted your copy & paste text to quote format by clicking the " (open double quote button) instead of the {} (double brace button) for code blocks. Second you didn't say which version of Ubuntu you were upgrading from. Third are you sure you ran sudo do-release-upgrade and not sudo do-release-upgrade -d? – WinEunuuchs2Unix May 5 '18 at 0:40
0

very old post this may not help you now but this will help other guys: to fix a broken update:

sudo apt-get install ubuntu-desktop
sudo apt update
sudo apt upgrade
sudo apt dist-upgrade
sudo apt autoremove

if you have customized so many things in your them older version and you want to go back to default theme

dconf reset -f /

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.