1

I had Ubuntu 17 and Windows 10 dual booted in my Lenovo Z51-70 laptop. Due to some issues in Windows 10, I needed to reinstall it. So, I created a bootable Windows 10 USB stick from Ubuntu by installing WinUSB as mentioned here [1].

sudo add-apt-repository ppa:colingille/freshlight
sudo apt-get update
sudo apt-get install winusb

They warned that

installing WinUSB on EFI loaded Ubuntu will uninstall the grub-efi packages in order to install the grub-pc packages. It will make your system unbootable if you don't manually reinstall grub-efi package before rebooting.

I didn't notice it and forgot to run the below commands before rebooting the system

sudo update-grub
sudo grub-install /dev/sda
sudo update-grub
sudo reboot

Hence my bootloader got corrupted, I tried everything but I am unable to reinstall windows and ubuntu. I tried following things which didn't work

  1. tried installing windows by booting from USB stick and DVD
  2. tried disabling secure boot in Bios
  3. tried refreshing system

Below [2] are the series of errors that I am getting when the system starts. I am stuck with this error from past 4-5 days, Any help would be appreciated

[1] How can I create a Windows bootable USB stick using Ubuntu?

[2] https://postimg.cc/gallery/fqdd2mni/

  • have you tried the boot-repair utility with live ubuntu? – kishea May 7 '18 at 13:33
  • @kishea Cannot boot anything from USB or DVD – Atinesh May 7 '18 at 14:24
1

You will need to boot your system using the Live/Try DVD:

More detail can be found here: How can I reinstall GRUB to the EFI partition?

| improve this answer | |
  • I tried it getting error EFI USB Device boot failed – Atinesh May 4 '18 at 20:40
  • Have you tried resetting your BIOS. From Lenovo site: Reset the BIOS to default: 1. Turn off notebook. 2. Remove AC adapter, main battery. 3. Press and hold down power button for 30 seconds (drains residual power). 4. Attach battery, AC adapter. 5. (Critical step) Boot up computer using "Novo" button only - enter BIOS and "set defaults" then "save and exit". – GeoCacheJunky May 4 '18 at 21:34
  • I tried resetting BIOS, but problem still persist. I cannot even find a way to factory reset. – Atinesh May 5 '18 at 6:42
  • I took my laptop to official Lenovo Service center and they gave up. They were suggesting replacing the entire motherboard although only BIOS chip was corrupt. So, I took it to the local service center and they repair it for around 80$. – Atinesh May 27 '18 at 8:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.