3

I was running Ubuntu 17.10 on my mac (mid-2010) as a dual-boot with Refind as the boot manager. It was functional albeit non-optimal drivers for wifi and video card.

A day ago, the Software Updater app gave me the option to upgrade and I took it. It completed the install and clean up fully but I was unable to do a final restart due to power issues. Anyway, after the power issues were sorted out, I booted my laptop, only to find that it wouldn't boot into the OS and would get stuck in a loop at a screen which was filled with lines of code that made no sense to me.

So, I rebooted with option key and booted into recovery mode and ran check disk and fix broken packages and then resumed boot. Then it booted into the OS fine. I rebooted again, and then it went back to the screen with lots of lines of code which no sense. I tried the same thing again with the recovery mode again. And this time when it booted I picked the proprietary Nvidia drivers. Now when I boot, there is just a blank screen and I cant boot into recovery mode either because there is an error in EFI screen option.

So I boot into OS X and download the ISO file for 18.04 and make a bootable USB stick and boot into that from the EFI screen. Now, it boots and once past the orangeish blue bionic beaver wallpapers, it gets stuck in a loop at a message called setting locale.

So, at this point, I can neither boot into my HDD Ubuntu install nor into the Live Disk.

My next plan of action is to try and get an ISO of a previous version and try booting form that. I'd like to avoid that if possible and stick to 18.04.

EDIT 1: I flashed Ubuntu 17.10 onto the USB storage, and that boots fine. I'll try 18.04 once again. Also, I'm using Unetbootin for flashing the USB storage.

EDIT 2: This keeps cycling over and over when I live booted from a freshly downloaded copy of Ubuntu 18.04 ISO file flashed in to a USB:

Screengrab of what happens when trying to boot from the USB

Keep in mind that when I do this on the same USB with the ISO file for 17.10.1, live boots perfectly fine.

EDIT 3: I've given up. I'm doing a clean install of 17.10.

1

I have pretty much the same issue on a mid-2010 MacBookPro 13 that single-boots Ubuntu. 17.10 worked fine. Upgraded to 18.04 by command line and now the graphical OS interface doesn't appear. I can SSH into the machine. I use the machine mostly as a file and web server, and those functionalities work correctly after the upgrade. The Nouveau video driver is in use, and text appears on the screen as described by numoonchld. I can get to text login using Ctl-Alt-F7. This is a Kubuntu installation, which uses sddm as the display manager/greeter. System log shows that sddm starts then exits. As part of diagnosing, I've installed Gnome desktop and it's gdm3 display manager/greeter, and got the essentially same result. Booting from USB device with 18.10 installation media hangs at some point with text on the screen. Because I use this machine as a server, I can live without the desktop, but I don't want to.

  • 1
    Welcome to Ask Ubuntu. This is not a proper answer to the question. Please consider improving it. – Archisman Panigrahi May 5 '18 at 17:48
1

I had the same issue on a mid-2010 MacBook Pro 13" which was running a single boot of Ubuntu 17.10 when I upgraded to 18.04.

After the upgrade, the boot sequence with default kernel Linux 4.15.0-20-generic is always stuck on an infinite log loop.

Luckily I had two kernels and GRUB configured to let me choose at startup which one to use. So I was able to boot properly using Linux 4.13.0-39-generic. Ubuntu 18.04 works fine so far with this kernel, so this made the trick for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.