12

I did a fresh install of Ubuntu 18.04, alongside Windows 10. On Ubuntu, one of my fans is extremely high, although the temperature is fine, and this is not happening on Windows. I've tried some of the solutions suggested in this forum, without success.

The one with the problem seems to be nct6775/fan2, at least it is the only one working at +1155 rpm, according to program HardInfo. My motherboard is an ASUS H81M-A.

  • What steps have you taken to address the fans specifically? Is fancontrol running? What does your /etc/fancontrol file look like? – rtaft May 9 '18 at 12:33
  • If you have an Intel CPU, try this: askubuntu.com/questions/516067/… – Claudio Taccogna May 12 '18 at 11:06
  • Try plugging the fan in a SYS fan header instead of a CPU header. For some motherboards I found out that the fan will try running at a higher speed than normal, and some CPU fans when plugged into the SYS header runs at a lower speed. Worth the shot though – dat tutbrus May 15 '18 at 23:14
7
+50

The typical steps for fancontrol setup include:

  • Running sensors-detect to ensure you have the correct modules and updates /etc/modules (/etc/sysconfig/lm_sensors on RH) to have the nct6775 entry.
  • Running pwmconfig to test and configure each fan and creates the /etc/fancontrol file.

There are known issues where sometimes the hwmon ids change between boots, leaving your fans out of control. For that you would manually edit your /etc/fancontrol file to include the full path of each pwm and replace the id with [[:print:]]* like so: /sys/devices/platform/nct6775.656/hwmon/hwmon[[:print:]]*/pwm1

These are actual paths on the files system that you can browse to get an idea of what is available.

You may also need to edit /etc/sensors3.conf, I had to add some stuff for the ASUS Z97, I posted those details on this thread.

You may also need to add the following to the GRUB_CMDLINE_LINUX_DEFAULT variable in the /etc/default/grub file: acpi_enforce_resources=lax then rebuild the grub config grub-mkconfig -o /boot/grub/grub.cfg

  • Thank you for your answer. I'll check this out. I've already installed lm-sensors and fancontrol. In pwmconfig, during the tests, my fan doesn't stop at all. I'll go over it again. – Esteban Knöbl May 9 '18 at 17:25
  • Did this work fine in Ubuntu 16? I don't have any control over my 3pin fans, only the 4pin ones. Most of my noise comes from the GPU fan. If you can see that it is fan2, you should be able to control it. Take a look at the filesystem, all fancontrol does is read/write the files in /sys/devices/platform/nct6775.656/hwmon/hwmon3/. Also lsmod and make sure nct6775 is loaded..and make sure your ASUS is using that chip (likely is). – rtaft May 9 '18 at 18:39
  • I have not installed any other version of Ubuntu in that PC, so I can't tell. I'll check what you suggest. Thankx! – Esteban Knöbl May 9 '18 at 19:47
4

I struggled with fan speed and thermal issues for a long time before I found tlp which has solved all my problems. You can learn more here:

TLP brings you the benefits of advanced power management for Linux without the need to understand every technical detail. TLP comes with a default configuration already optimized for battery life, so you may just install and forget it. Nevertheless TLP is highly customizable to fulfill your specific requirements.

Installation is the predictable

sudo apt install tlp

Configuration is automatic and I've never had to change it out of the box.


If tlp by itself doesn't solve all your thermal issues there are specific steps you can take for ASUS Laptops:

Kernel modules overview

  • asus-nb-wmi is a kernel module, which is included in mainstream Linux kernel and is loaded automatically in Asus laptops. It will only allow to control a single fan and if there is a second fan - you will not have any controls over it. Blacklisting this module will prevent keyboard backlight to work.
  • asus_fan is a kernel module, which allows to control both fans on some older Asus laptops. Does not work with the most recent models.

For myself after installing tlp I was able to remove a couple of fan control programs I had struggled to setup for my laptop. However I do not have an ASUS so you might need something more than just tlp.

1

There can be two things at play here and for that there are two things you can do/try.

1. Check BIOS settings.

certain settings can be found/only be found in the BIOS, one of these settings that can be found in the BIOS are the fan settings, you can check here if there is something wrong there.

2. Sensor broke

It is possible that the sensor of the fan might have broken, i know there is away to check that with a GUI with Ubuntu and Windows so i will explain both.

Ubuntu

To check your sensor with Ubuntu you need to have hardinfo installed you do this by using the command sudo apt-get install hardinfo with this you can see if the sensor is okay or broken.

Windows

To check your sensor with Windows you will need to install Speedfan which can be found here. it will show you the temperatures your fansensors are reading and the speed of your fans

(side note: it has been a while since i used these programs so they might be different then i remember them)

i hope this will solve your problem cause it did for me

  • 2
    Hello, friend. I think yours is more a comment than an answer. Plus, it shows you did not read my question properly. Please, post it as a comment instead. – Esteban Knöbl May 9 '18 at 11:44
  • @estebanknobl i would do so if i could since commenting is only available with a rep of 50, but i forgot about a third option which is highly doubt-able but possible and that is it is wrongly wired, should i add this to the answer as well? – delfiler May 9 '18 at 12:31
  • @estebanknobl secondly 'I've tried some of the solutions suggested in this forum' isn't very clear on what you have tried i mean you might have missed one of the two i mentioned (as i missed/blanked on the part of 'hardinfo' (yes i have memory problems)) – delfiler May 9 '18 at 12:54
0

fan speed can be monitored from bios. try to change the settings there to "silent mode" in Q-fan configuration. to get there you can use this video: https://www.youtube.com/watch?v=8wMrCsFxLTQ&t=58s

0

I had the very same problem after replacing the motherboard. I finally found that I had forgotten to reconnect the sensor cable to the new motherboard. The sensor cable is small 4 pin plug. The socket for it is located on the right-front side of the board (looking at the front of the computer). It's very easy to overlook connecting it. My computer ran very quit as soon as the sensor was reconnected.

0

I was having problems with Ubuntu 18.04 on my Asus laptop Q551L and high fan speed when coming out of sleep. My laptop had nvidia devices needing drivers including my video card GM108M GeForce 840M. Here's what fixed it for me as explained on this page.

$ ubuntu-drivers devices
$ sudo ubuntu-drivers autoinstall

Then reboot.

0

I had same problem with my Asus BM6820 desktop & Nvidia GeForce GT 730. I've tried all of the tips above, but finally found, the kernel's stock Nvidia driver : nouveau caused the problem ! Boot your pc to init 3 runlevel to verify this problem. If the fan speed is OK, you can try to disable nvidia nouveau driver :

How to disable Nouveau nvidia driver

https://linuxconfig.org/how-to-disable-nouveau-nvidia-driver-on-ubuntu-18-04-bionic-beaver-linux

$ sudo bash -c "echo blacklist nouveau > /etc/modprobe.d/blacklist-nvidia-nouveau.conf"

$ sudo bash -c "echo options nouveau modeset=0 >> /etc/modprobe.d/blacklist-nvidia-nouveau.conf"

Confirm the content of the new modprobe config file:

$ cat /etc/modprobe.d/blacklist-nvidia-nouveau.conf
blacklist nouveau
options nouveau modeset=0

Then install the proper Nvidia driver from Nvidia's site :

https://linuxconfig.org/how-to-install-the-nvidia-drivers-on-ubuntu-18-04-bionic-beaver-linux

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.